summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
-rw-r--r--buildCabbage.patch63
3 files changed, 83 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0950aa0d030c..f7edc1732325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cabbage-git
pkgdesc = A framework for audio software development
- pkgver = 2.0.0r1188
+ pkgver = 2.0.0r1225
pkgrel = 1
url = http://cabbageaudio.com/
arch = x86_64
@@ -23,13 +23,13 @@ pkgbase = cabbage-git
conflicts = cabbage
source = git+https://github.com/rorywalsh/cabbage.git#branch=master
source = git+https://github.com/WeAreROLI/JUCE.git#tag=5.2.0
- source = fix_default_dirs.patch
+ source = buildCabbage.patch
source = cabbage.png
source = Cabbage.desktop
source = CabbageLite.desktop
md5sums = SKIP
md5sums = SKIP
- md5sums = 44c102c1fbd8e5b1e784136f3bcba7dd
+ md5sums = 123ac4cc22f58bb00e2dd34a290f3156
md5sums = c3c8e35dd46c86f22a3565aa4dd828a8
md5sums = 35cfc89844c90769f4dc4f8309b340b1
md5sums = c39a85709e31e03a0850f2e324a4faea
diff --git a/PKGBUILD b/PKGBUILD
index ab08f703eec0..cc3e1179ce32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Eugene Cherny <iam@oscii.ru>
pkgname=cabbage-git
pkgrel=1
-pkgver=2.0.0r1188
+pkgver=2.0.0r1225
pkgdesc='A framework for audio software development'
arch=('x86_64')
url="http://cabbageaudio.com/"
@@ -13,13 +13,13 @@ conflicts=('cabbage')
provides=('cabbage')
source=('git+https://github.com/rorywalsh/cabbage.git#branch=master'
'git+https://github.com/WeAreROLI/JUCE.git#tag=5.2.0'
- 'fix_default_dirs.patch'
+ 'buildCabbage.patch'
'cabbage.png'
'Cabbage.desktop'
'CabbageLite.desktop')
md5sums=('SKIP'
'SKIP'
- '44c102c1fbd8e5b1e784136f3bcba7dd'
+ '123ac4cc22f58bb00e2dd34a290f3156'
'c3c8e35dd46c86f22a3565aa4dd828a8'
'35cfc89844c90769f4dc4f8309b340b1'
'c39a85709e31e03a0850f2e324a4faea')
@@ -85,7 +85,9 @@ prepare() {
sed -i "/CabbageBuild\/cabbage.desktop/d" "$b"
dos2unix "${srcdir}/cabbage/Source/Settings/CabbageSettings.cpp"
- patch -p1 < ../../fix_default_dirs.patch
+
+ cd "$srcdir"
+ patch -p0 < buildCabbage.patch
}
pkgver() {
@@ -113,17 +115,20 @@ build() {
}
package() {
- install -Dm644 cabbage.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/cabbage.png"
- install -Dm644 Cabbage.desktop "${pkgdir}/usr/share/applications/Cabbage.desktop"
- install -Dm644 Cabbage.desktop "${pkgdir}/usr/share/applications/CabbageLite.desktop"
+ cabbage_install_dir="${srcdir}/cabbage/Builds/LinuxMakefile/install"
+ images_dir="${pkgdir}/usr/share/icons/hicolor/512x512/apps"
- cd "${srcdir}/cabbage/Builds/LinuxMakefile/CabbageBuild/"
+ install -d "$images_dir"
+ for file in "${cabbage_install_dir}"/images/*; do
+ install -m644 "$file" "$images_dir"
+ done
- for f in Cabbage CabbageLite CabbagePluginEffect.so CabbagePluginSynth.so opcodes.txt; do
- install -Dm755 "$f" "${pkgdir}/usr/bin/$f"
+ install -d "${pkgdir}/usr/bin"
+ for file in "${cabbage_install_dir}"/bin/*; do
+ install -m755 "$file" "${pkgdir}/usr/bin/"
done
- install -d "${pkgdir}/usr/share/doc/cabbage/examples"
- cp -r Examples/* "${pkgdir}/usr/share/doc/cabbage/examples/"
+ install -d "${pkgdir}/usr/share/doc/cabbage"
+ cp -r "${cabbage_install_dir}/Examples" "${pkgdir}/usr/share/doc/cabbage"
chmod -R 755 "${pkgdir}/usr/share/doc/cabbage"
}
diff --git a/buildCabbage.patch b/buildCabbage.patch
new file mode 100644
index 000000000000..e79e8517bcb5
--- /dev/null
+++ b/buildCabbage.patch
@@ -0,0 +1,63 @@
+--- cabbage/Builds/LinuxMakefile/buildCabbage 2018-05-26 02:00:50.542132073 -0400
++++ cabbage/Builds/LinuxMakefile/buildCabbage.new 2018-05-26 02:17:29.522074962 -0400
+@@ -35,46 +35,48 @@
+ make -f MakePluginSynth -j6
+ else
+ #release mode default
++
++mkdir -p ./install/bin ./install/images
++
+ ../../../JUCE/extras/Projucer/Builds/LinuxMakefile/build/Projucer --resave ../../CabbageIDE.jucer
+ mv Makefile MakeCabbageIDE
+ make -f MakeCabbageIDE clean CONFIG=Release
+ make -f MakeCabbageIDE -j6 CONFIG=Release
+-cp ./build/Cabbage /usr/bin/Cabbage
++cp ./build/Cabbage ./install/bin/Cabbage
+
+ ../../../JUCE/extras/Projucer/Builds/LinuxMakefile/build/Projucer --resave ../../CabbagePlugin.jucer
+ mv Makefile MakePluginEffect
+
+ make -f MakePluginEffect clean CONFIG=Release
+ make -f MakePluginEffect -j6 CONFIG=Release
+-cp ./build/CabbagePlugin.so /usr/bin/CabbagePluginEffect.so
++cp ./build/CabbagePlugin.so ./install/bin/CabbagePluginEffect.so
+
+ ../../../JUCE/extras/Projucer/Builds/LinuxMakefile/build/Projucer --resave ../../CabbagePluginSynth.jucer
+ mv Makefile MakePluginSynth
+
+ make -f MakePluginSynth clean CONFIG=Release
+ make -f MakePluginSynth -j6 CONFIG=Release
+-cp ./build/CabbagePlugin.so /usr/bin/CabbagePluginSynth.so
++cp ./build/CabbagePlugin.so ./install/bin/CabbagePluginSynth.so
+
+ ../../../JUCE/extras/Projucer/Builds/LinuxMakefile/build/Projucer --resave ../../CabbageLite.jucer
+ mv Makefile MakeCabbageLite
+
+ make -f MakeCabbageLite clean CONFIG=Release
+ make -f MakeCabbageLite -j6 CONFIG=Release
+-cp ./build/CabbageLite /usr/bin/CabbageLite
++cp ./build/CabbageLite ./install/bin/CabbageLite
+
+ fi
+
+-cp ./../opcodes.txt /usr/bin/opcodes.txt
+-cp ./../../Images/cabbage.png /usr/share/icons/hicolor/512x512/apps/cabbage.png
+-cp ./../../Images/cabbage.png /usr/share/icons/hicolor/512x512/apps/cabbagelite.png
+-mkdir /usr/share/doc/cabbage/
+-cp -rf ../../Examples/ /usr/share/doc/cabbage/Examples
++cp ./../opcodes.txt ./install/bin/opcodes.txt
++cp ./../../Images/cabbage.png ./install/images/cabbage.png
++cp ./../../Images/cabbage.png ./install/images/cabbagelite.png
++cp -rf ../../Examples ./install/
+
+ g++ ../../Source/testCsoundFile.cpp -o testCsoundFile -I"/usr/include/csound" -lcsound64
+-cp testCsoundFile /usr/bin/testCsoundFile
++cp testCsoundFile ./install/bin/testCsoundFile
+ #cp -rf ../../Docs/_book CabbageBuild/Docs
+
+ sed "s@CURRENTDIR@$(pwd)@" Cabbage.desktop > cabbage.desktop
+ sed "s@CURRENTDIR@$(pwd)@" Cabbage.desktop > cabbagLite.desktop
+-# sed "s@CURRENTDIR@$(pwd)@" dummy.desktop > CabbageBuild/cabbagelite.desktop
+-cp cabbage.desktop ~/.local/share/applications/
++#sed "s@CURRENTDIR@$(pwd)@" dummy.desktop > CabbageBuild/cabbagelite.desktop
++cp cabbage.desktop ./install/