summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD60
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87295faeb1c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cainteoir-gtk
+ pkgdesc = The Cainteoir Text-To-Speach Engine, GTK Frontend and ebook reader
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/rhdunn/cainteoir-gtk
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = gtk3
+ depends = caintenoir-engine
+ source = https://github.com/rhdunn/cainteoir-gtk/archive/cainteoir-gtk-0.9.tar.gz
+ md5sums = 4f409585591ad5ae5128f540de6070e8
+
+pkgname = cainteoir-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b80bf953ac2f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=cainteoir-gtk
+pkgver=0.9
+pkgrel=1
+epoch=
+pkgdesc="The Cainteoir Text-To-Speach Engine, GTK Frontend and ebook reader"
+arch=(x86_64)
+url="https://github.com/rhdunn/cainteoir-gtk"
+license=('GPL')
+groups=()
+depends=(gtk3 caintenoir-engine)
+makedepends=(intltool)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(
+"https://github.com/rhdunn/cainteoir-gtk/archive/$pkgname-$pkgver.tar.gz"
+)
+noextract=()
+md5sums=(
+4f409585591ad5ae5128f540de6070e8
+)
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgname-$pkgver"
+ #cp -R ucd-tools-8.0.0/* "$pkgname-$pkgname-$pkgver/ucd-tools"
+ #sed -i 's/python/python2/g' "$pkgname-$pkgname-$pkgver/tools/fsm"
+}
+
+build() {
+ cd "$pkgname-$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgname-$pkgver"
+ #make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+ #cd $pkgdir/usr/share
+ #rm -rf mime vim
+}
+