summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f60fb0926a1..2f0e4c6df8c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = californium-tools-git
pkgdesc = Californium tools, including cf-client, cf-server and cf-browser.
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
url = https://eclipse.dev/californium/
arch = x86_64
license = Eclipse Distribution License 1.0 or Eclipse Public License 2.0
depends = maven
depends = liberica-jdk-11-full-bin
+ depends = coreutils
source = git+https://github.com/eclipse-californium/californium.tools.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0eac319f3d97..b723aedf926e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname="californium-tools-git"
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="Californium tools, including cf-client, cf-server and cf-browser."
url="https://eclipse.dev/californium/"
@@ -7,14 +7,14 @@ arch=("x86_64")
license=("Eclipse Distribution License 1.0 or Eclipse Public License 2.0")
makedepends=()
optdepends=()
-depends=('maven' 'liberica-jdk-11-full-bin')
+depends=('maven' 'liberica-jdk-11-full-bin' 'coreutils')
source=("git+https://github.com/eclipse-californium/californium.tools.git")
sha256sums=("SKIP")
build() {
cd "$srcdir/californium.tools"
export JAVA_HOME="/usr/lib/jvm/liberica-jdk-11-full"
- mvn clean install -Daether.dependencyCollector.impl=bf
+ mvn -T $(nproc) clean install -Daether.dependencyCollector.impl=bf
rm -fr jars bin applications
mkdir jars bin applications
@@ -28,7 +28,7 @@ build() {
echo "#!/bin/sh
export JAVA_HOME='/usr/lib/jvm/liberica-jdk-11-full'
-/usr/lib/jvm/liberica-jdk-11-full/bin/java -jar /usr/share/californium-tools/jars/$identifier.jar
+/usr/lib/jvm/liberica-jdk-11-full/bin/java -jar /usr/share/californium-tools/jars/$identifier.jar "'$@'"
" > "bin/$identifier"
chmod a+x "bin/$identifier"