summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.index.json2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.index.json b/.index.json
index 227622cacb34..9cc1fbd015c7 100644
--- a/.index.json
+++ b/.index.json
@@ -1,5 +1,5 @@
{
- ".i": 1,
+ ".i": 2,
"crate": "cargo-clean-all",
"version": "0.6.2"
} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index f8596b1c6935..054ad870f338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,14 @@ license=('MIT')
depends=('gcc-libs')
makedepends=('cargo')
-source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.6.2/download")
+source=("$_crate-0.6.2.tar.gz::https://crates.io/api/v1/crates/cargo-clean-all/0.6.2/download")
sha512sums=('dd3b1940ba418d73d85c861bc30ec443b522d20986e9400dbafdb6f16243407ca2cde5392c60cb25e5cd71014feebac7a78269257a00a6b58152295a54f71d3f')
# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
arch=('aarch64' 'i686' 'x86_64')
prepare() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.6.2"
export RUSTUP_TOOLCHAIN=stable
@@ -27,10 +27,11 @@ prepare() {
}
build() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.6.2"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
+ CFLAGS+=" -ffat-lto-objects"
cargo build \
@@ -40,7 +41,7 @@ build() {
}
package() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.6.2"
install -Dm755 "target/release/cargo-clean-all" -t "$pkgdir/usr/bin"
install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$pkgname/"
} \ No newline at end of file