summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD48
-rw-r--r--castles-in-the-sky8
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b01335ffa904
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = castles-in-the-sky
+ pkgdesc = A game by the Tall Trees
+ pkgver = 1
+ pkgrel = 3
+ url = http://thetalltreesgames.co.uk/CastlesInTheSky/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = p7zip
+ depends = wine
+ noextract = castlesinthesky_win_12232013.exe
+ source = castles-in-the-sky
+ md5sums = 67b7e26884e1cc0d73c338e531ebff2a
+
+pkgname = castles-in-the-sky
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f181b12bb258
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Can Celasun <dcelasun[at]gmail[dot]com>
+pkgname=castles-in-the-sky
+pkgver=1
+pkgrel=3
+pkgdesc="A game by the Tall Trees"
+arch=(i686 x86_64)
+url="http://thetalltreesgames.co.uk/CastlesInTheSky/"
+license=('custom')
+depends=(wine)
+makedepends=(p7zip)
+_sourcefile=castlesinthesky_win_12232013.exe
+noextract=(${_sourcefile})
+source=(castles-in-the-sky)
+md5sums=('67b7e26884e1cc0d73c338e531ebff2a')
+
+package() {
+ msg "You need a full copy of this game in order to install it"
+ msg "Searching for ${_sourcefile} in dir: \"$startdir\""
+ pkgpath="$startdir"
+ if [[ ! -f "${pkgpath}/${_sourcefile}" ]]; then
+ error "Game installer not found, please type absolute path to ${_sourcefile} (/home/joe):"
+ read pkgpath
+ if [[ ! -f "${pkgpath}/${_sourcefile}" ]]; then
+ error "Unable to find game package." && return 1
+ fi
+ fi
+ msg "Found game package, unpacking..."
+
+ cd "${srcdir}"
+
+ 7z x -aoa -o"${srcdir}/exe" ${pkgpath}/${_sourcefile}
+
+ install -d -m755 "${pkgdir}/usr/share/${pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ cp -ra "${srcdir}"/exe/* "${pkgdir}/usr/share/${pkgname}"
+ cp "${srcdir}/exe/License.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ find "${pkgdir}/usr/share/${pkgname}" -type d -exec chmod 755 "{}" \;
+ find "${pkgdir}/usr/share/${pkgname}" -type f -exec chmod 644 "{}" \;
+
+
+ # Remove spaces in the exe file
+ mv "${pkgdir}/usr/share/${pkgname}/Castles in the Sky.exe" "${pkgdir}/usr/share/${pkgname}/CastlesInTheSky.exe"
+
+ install -d -m755 "${pkgdir}/usr/bin"
+ install -m755 castles-in-the-sky "${pkgdir}/usr/bin"
+}
diff --git a/castles-in-the-sky b/castles-in-the-sky
new file mode 100644
index 000000000000..af9bf8bd7781
--- /dev/null
+++ b/castles-in-the-sky
@@ -0,0 +1,8 @@
+#!/bin/bash
+unset WINEPREFIX
+if [ ! -d "$HOME"/.castles-in-the-sky ] ; then
+ mkdir -p "$HOME"/.castles-in-the-sky
+ #prepare the environment here
+fi
+
+WINEPREFIX="$HOME"/.castles-in-the-sky WINEDEBUG=-all wine /usr/share/castles-in-the-sky/CastlesInTheSky.exe