summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bab338bcc1dc..ee0daea51df0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = catgirl-engine-git
pkgdesc = A game engine for cool moddability and procedurally generated data
pkgver = v0.12.32.r1.g996abc2
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/lexi-the-cute/catgirl-engine
arch = any
license = Zlib
@@ -9,6 +9,8 @@ pkgbase = catgirl-engine-git
makedepends = rustup
makedepends = cargo-nightly
makedepends = sed
+ optdepends = wayland: Graphics display server
+ optdepends = xorg-server: Graphics display server
provides = catgirl-engine=v0.12.32
conflicts = catgirl-engine
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index bd333d495f21..bb4cdaa8b473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ arch=('any')
license=(Zlib)
url="https://github.com/lexi-the-cute/catgirl-engine"
pkgver=v0.12.32.r1.g996abc2
-pkgrel=4
+pkgrel=5
provides=("catgirl-engine=${pkgver%%.r*}")
conflicts=(catgirl-engine)
source=("git+https://github.com/lexi-the-cute/catgirl-engine.git")
@@ -19,11 +19,14 @@ makedepends=(
"cargo-nightly"
"sed"
)
+optdepends=(
+ "wayland: Graphics display server"
+ "xorg-server: Graphics display server"
+)
# Automatically updates pkgver variable
pkgver() {
cd "catgirl-engine"
- rustup install nightly
git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -31,6 +34,7 @@ pkgver() {
prepare() {
export RUSTUP_TOOLCHAIN=nightly
cd "catgirl-engine"
+ rustup install nightly
cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}