summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
-rw-r--r--rlwrap-shim8
3 files changed, 8 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59d69335d4db..a766d0f5980b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cbqn-git
pkgdesc = A BQN implementation in C.
pkgver = r1761.fef8cfa
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dzaima/CBQN
arch = x86_64
arch = i686
@@ -11,20 +11,14 @@ pkgbase = cbqn-git
license = Boost
license = GPL3
license = MIT
- license = custom:ISC
makedepends = git
makedepends = clang
depends = glibc
depends = libffi
optdepends = ttf-bqn386: BQN and APL compatible font
- optdepends = rlwrap: Use readline in the REPL
provides = cbqn
conflicts = cbqn
source = cbqn::git+https://github.com/dzaima/CBQN.git
- source = BQN-ref::git+https://github.com/mlochbaum/BQN.git
- source = rlwrap-shim
md5sums = SKIP
- md5sums = SKIP
- md5sums = 7f5146ad32f69dc96844ee495e4f6e83
pkgname = cbqn-git
diff --git a/PKGBUILD b/PKGBUILD
index 9b7793dde756..2907fce94e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,18 @@
# Maintainer: Firegem <mrfiregem [at] protonail [dot] ch>
pkgname=cbqn-git
pkgver=r1761.fef8cfa
-pkgrel=1
+pkgrel=2
pkgdesc="A BQN implementation in C."
arch=('x86_64' 'i686' 'aarch64' 'arm')
url="https://github.com/dzaima/CBQN"
-license=('Apache' 'Boost' 'GPL3' 'MIT' 'custom:ISC')
+license=('Apache' 'Boost' 'GPL3' 'MIT')
depends=('glibc' 'libffi')
-optdepends=('ttf-bqn386: BQN and APL compatible font'
- 'rlwrap: Use readline in the REPL')
+optdepends=('ttf-bqn386: BQN and APL compatible font')
makedepends=('git' 'clang')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+${url}.git"
- 'BQN-ref::git+https://github.com/mlochbaum/BQN.git'
- 'rlwrap-shim')
-md5sums=('SKIP'
- 'SKIP'
- '7f5146ad32f69dc96844ee495e4f6e83')
+source=("${pkgname%-git}::git+${url}.git")
+md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
@@ -26,25 +21,11 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-git}"
- make PIE='-pie' LDFLAGS="${LDFLAGS}" t='aur' f='-O2' c
-}
-
-check() {
- cd "${srcdir}/${pkgname%-git}"
- ./BQN "${srcdir}/BQN-ref/test/this.bqn"
+ make PIE='-pie' LDFLAGS="${LDFLAGS}" REPLXX=1 t='aur' f='-O2' c
}
package() {
- # Script to allow inputting special characters if rlwrap is installed
- install -Dm755 ./rlwrap-shim "${pkgdir}/usr/bin/bqn"
-
cd "${srcdir}/${pkgname%-git}"
- # The actual cbqn binary
- install -Dm755 -t "${pkgdir}/usr/share/${pkgname}" BQN
+ install -Dm755 BQN "${pkgdir}/usr/bin/bqn"
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" licenses/*
-
- cd "${srcdir}/BQN-ref"
- # inputrc file used by shim
- install -Dm644 -t "${pkgdir}/usr/share/${pkgname}" editors/inputrc
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-BQN"
}
diff --git a/rlwrap-shim b/rlwrap-shim
deleted file mode 100644
index c93ad00b05c9..000000000000
--- a/rlwrap-shim
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-pkgdir=/usr/share/cbqn-git
-
-if command -v 'rlwrap' >/dev/null; then
- INPUTRC="${pkgdir}/inputrc" rlwrap "${pkgdir}/BQN" "$@"
-else
- "${pkgdir}/BQN" "$@"
-fi