summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
-rw-r--r--cchost.install9
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcf982b2d335
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cchost
+ pkgdesc = Web-based System Supporting Remixing and Collaboration on Media
+ pkgver = 5.1
+ pkgrel = 2
+ url = http://wiki.creativecommons.org/CcHost
+ install = cchost.install
+ arch = any
+ license = GPL
+ depends = php
+ options = !strip
+ backup = etc/webapps/cchost/.htaccess
+ source = http://downloads.sourceforge.net/cctools/cchost-5.1.zip
+ source = http://downloads.sourceforge.net/sourceforge/getid3/getid3-1.9.3-20111213.zip
+ md5sums = 723ed665a52b2b666811499b13f7dfe2
+ md5sums = 00990e23f4035c29974d025cc5f3eeb7
+
+pkgname = cchost
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16458aca2dac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: PKGBUILD 194152 2016-10-31 13:48:24Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=cchost
+pkgver=5.1
+_getid3ver=1.9.3-20111213
+pkgrel=2
+pkgdesc="Web-based System Supporting Remixing and Collaboration on Media"
+arch=(any)
+url="http://wiki.creativecommons.org/CcHost"
+license=('GPL')
+depends=('php')
+install=cchost.install
+backup=('etc/webapps/cchost/.htaccess')
+options=('!strip')
+source=(http://downloads.sourceforge.net/cctools/cchost-$pkgver.zip
+ http://downloads.sourceforge.net/sourceforge/getid3/getid3-${_getid3ver}.zip)
+md5sums=('723ed665a52b2b666811499b13f7dfe2'
+ '00990e23f4035c29974d025cc5f3eeb7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # python2 fix
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' bin/publishcchost
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir"/usr/share/webapps
+ mkdir -p "$pkgdir"/etc/webapps/cchost
+ cp -a "$srcdir"/$pkgname-$pkgver "$pkgdir"/usr/share/webapps/cchost
+ cp -a "$srcdir"/getid3 "$pkgdir"/usr/share/webapps/cchost/getid3
+
+ cd "$pkgdir"/usr/share/webapps/cchost
+
+ echo "deny from all" >"$pkgdir"/etc/webapps/cchost/.htaccess
+ ln -s /etc/webapps/cchost/.htaccess .htaccess
+
+ find "$pkgdir"/usr/share/webapps/cchost -type f -exec chmod 0644 {} \;
+}
diff --git a/cchost.install b/cchost.install
new file mode 100644
index 000000000000..f0cc6c41b6e9
--- /dev/null
+++ b/cchost.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "-- Don't forget to set proper file access according to your web server setting!"
+ mkdir -p var/log/cchost
+ chown http:http var/log/cchost
+}
+
+post_upgrade() {
+ echo "-- Don't forget to set proper file access according to your web server setting!"
+}