summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52e41018af46..05933d5dd9a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = ccluster
pkgdesc = local clustering of complex roots of a univariate polynomial with complex coefficients
- pkgver = 1.1.5
+ pkgver = 1.1.7
pkgrel = 1
url = https://github.com/rimbach/Ccluster
arch = i686
arch = x86_64
license = LGPL2.1
- depends = arb
- depends = flint
+ depends = flint>=3.0.0
depends = gmp
- source = https://github.com/rimbach/Ccluster/archive/refs/tags/v1.1.5.tar.gz
- sha256sums = 42aeaa9a5a9ffba183378eb1d1cd9ade070919a3dbb73c6e264b1b6bf2ae5d48
+ source = https://github.com/rimbach/Ccluster/archive/refs/tags/v1.1.7.tar.gz
+ sha256sums = 725ab22cf7e74afe5a5133ac75ee4a101d7b4ff5f0f25a6b74f5d9bfda8a18d5
pkgname = ccluster
-
diff --git a/PKGBUILD b/PKGBUILD
index 1e560d03f2d6..6fce8b65258d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,36 @@
# Maintainer: Alexander Kobel <a-kobel@a-kobel.de>
pkgname=ccluster
-pkgver=1.1.5
+pkgver=1.1.7
pkgrel=1
pkgdesc="local clustering of complex roots of a univariate polynomial with complex coefficients"
url="https://github.com/rimbach/Ccluster"
arch=('i686' 'x86_64')
license=('LGPL2.1')
-depends=('arb' 'flint' 'gmp')
+depends=('flint>=3.0.0' 'gmp')
source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('42aeaa9a5a9ffba183378eb1d1cd9ade070919a3dbb73c6e264b1b6bf2ae5d48')
+sha256sums=('725ab22cf7e74afe5a5133ac75ee4a101d7b4ff5f0f25a6b74f5d9bfda8a18d5')
+
+prepare () {
+ cd "${srcdir}/Ccluster-${pkgver}"
+ # arb is included in flint since flint-3.0.0; do not link explicitly
+ find . -type f -iname 'makefile*' -exec sed -i -e s/-larb// {} +
+ sed -i -e 's/LIBS="${LIBS} arb"//' ./configure
+ # arb_poly_taylor_shift_convolution is not available anymore
+ find . -type f -name '*.c' -exec sed -i -r 's/(a[rc]b)_poly_taylor_shift_convolution/\1_poly_taylor_shift/g' {} +
+}
build () {
cd "${srcdir}/Ccluster-${pkgver}"
- CFLAGS="-fcommon ${CFLAGS} ${LDFLAGS}" ./configure --with-arb=/usr --with-flint=/usr --with-gmp=/usr --prefix="${pkgdir}/usr"
+ CFLAGS="-fcommon ${CFLAGS} ${LDFLAGS} -I/usr/include/flint" ./configure --with-flint=/usr --with-gmp=/usr --prefix="${pkgdir}/usr"
make bins
}
check () {
- cd "${srcdir}/Ccluster-${pkgver}"
+ cd "${srcdir}/Ccluster-${pkgver}/test"
# hide gnuplot to make non-interactive
sed -i -e 's/| gnuplot/| true/' Makefile
- make test
+ PATH="$(pwd):${PATH}" make testVerbose
}
package () {