summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb435fbfe8ac..d4b1d6cd763b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-# Generated by mksrcinfo v8
-# Wed Oct 23 14:08:24 UTC 2019
pkgbase = cdetect
pkgdesc = Detect which compiler version was used for compiling an ELF file
- pkgver = 0.5.4
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/xyproto/cdetect
arch = x86_64
- license = MIT
+ license = BSD
makedepends = go
makedepends = git
- source = git+https://github.com/xyproto/cdetect#tag=0.5.4
- sha256sums = SKIP
+ source = git+https://github.com/xyproto/cdetect#commit=3873c8b2d44a7ccdb3cff780ac4320cbc7af2ccc
+ b2sums = SKIP
pkgname = cdetect
-
diff --git a/PKGBUILD b/PKGBUILD
index 38cc9e31fa1b..3d1ce66c94e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=cdetect
-pkgver=0.5.4
+pkgver=0.6.0
pkgrel=1
pkgdesc='Detect which compiler version was used for compiling an ELF file'
-arch=('x86_64')
+arch=(x86_64)
url='https://github.com/xyproto/cdetect'
-license=(MIT)
+license=(BSD)
makedepends=(go git)
-source=("git+https://github.com/xyproto/cdetect#tag=$pkgver")
-sha256sums=('SKIP')
+source=("git+https://github.com/xyproto/cdetect#commit=3873c8b2d44a7ccdb3cff780ac4320cbc7af2ccc") # tag: 0.6.0
+b2sums=('SKIP')
build() {
- cd "$pkgname"
-
- go build -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
+ cd $pkgname
+ go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags $LDFLAGS"
}
package() {
- install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 $pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et: