summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a01645dbad34..8e207ab9b761 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,17 @@
pkgbase = certbot-git
pkgdesc = Tool to automatically receive and install X.509 certificates to enable TLS on servers
- pkgver = 2.6.0.r10.g2d8a274eb
+ pkgver = 2.8.0.r6.g926d0c7e0
pkgrel = 1
url = https://certbot.eff.org/
arch = any
license = Apache
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
depends = ca-certificates
depends = python-acme-git
depends = python-configargparse
@@ -16,14 +22,10 @@ pkgbase = certbot-git
depends = python-parsedatetime
depends = python-pyrfc3339
depends = python-pytz
- depends = python-setuptools
- depends = python-zope-component
- depends = python-zope-interface
- depends = python-httplib2
optdepends = certbot-apache-git: Apache plugin for Let’s Encrypt client
optdepends = certbot-nginx-git: Nginx plugin for Let’s Encrypt client
- provides = certbot=2.6.0.r10.g2d8a274eb
- provides = letsencrypt=2.6.0.r10.g2d8a274eb
+ provides = certbot=2.8.0.r6.g926d0c7e0
+ provides = letsencrypt=2.8.0.r6.g926d0c7e0
conflicts = certbot
conflicts = letsencrypt
replaces = letsencrypt-git
diff --git a/PKGBUILD b/PKGBUILD
index 55af33f6af09..4b08cbc21885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=certbot-git
_reponame="certbot"
-pkgver=2.6.0.r10.g2d8a274eb
+pkgver=2.8.0.r6.g926d0c7e0
pkgrel=1
pkgdesc="Tool to automatically receive and install X.509 certificates to enable TLS on servers"
arch=('any')
@@ -11,11 +11,10 @@ url="https://certbot.eff.org/"
# Most AUR helpers unfortunately do not support versioned deps in the AUR ("python-acme=${pkgver}")
depends=('ca-certificates' 'python-acme-git' 'python-configargparse' 'python-configobj'
'python-cryptography' 'python-distro' 'python-josepy' 'python-parsedatetime'
- 'python-pyrfc3339' 'python-pytz' 'python-setuptools' 'python-zope-component'
- 'python-zope-interface' 'python-httplib2')
+ 'python-pyrfc3339' 'python-pytz')
optdepends=("certbot-apache-git: Apache plugin for Let’s Encrypt client"
"certbot-nginx-git: Nginx plugin for Let’s Encrypt client")
-makedepends=('git')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools' 'python-sphinx' 'python-sphinx_rtd_theme')
provides=("certbot=${pkgver}" "letsencrypt=${pkgver}")
conflicts=("certbot" "letsencrypt")
replaces=("letsencrypt-git")
@@ -30,24 +29,26 @@ pkgver() {
)
}
+prepare() {
+ git -C "${srcdir}/${_reponame}" clean -dfx
+}
+
build() {
- # Enter the directory with the build files
cd "${srcdir}/${_reponame}/certbot"
-
- # Clean up build environment
- python setup.py clean
- rm -rf build dist
-
- # Build the package using python
- python setup.py build
+ python -m build --wheel --no-isolation
+ make -C docs man # man pages
}
package() {
# Enter the directory with the build files
cd "${srcdir}/${_reponame}/certbot"
- # Install files
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ chmod 755 "${pkgdir}"/usr/bin/*
+
+ install -vDm644 -t "${pkgdir}/usr/share/man/man1" docs/_build/man/*.1
+ install -vDm644 -t "${pkgdir}/usr/share/man/man7" docs/_build/man/*.7
# Create configuration, log and lib directories
install -d "${pkgdir}"/etc/letsencrypt