aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO39
-rw-r--r--LICENSE61
-rw-r--r--PKGBUILD58
-rw-r--r--README.md6
-rw-r--r--cevelop.install11
-rwxr-xr-xcevelop.sh7
6 files changed, 182 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0da3e14b2fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = cevelop
+ pkgdesc = The C++ IDE for professional developers
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://www.cevelop.com
+ install = cevelop.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gendesk
+ makedepends = libarchive
+ depends = java-environment
+ depends = webkitgtk2
+ depends = unzip
+ depends = glibc>2.14
+ depends = python
+ optdepends = hicolor-icon-theme
+ provides = cevelop
+ source = cevelop.sh
+ source = LICENSE
+ source = https://github.com/Cevelop/cevelop.github.io/raw/master/img/logo-square-16.png
+ source = https://github.com/Cevelop/cevelop.github.io/raw/master/img/logo-square-32.png
+ source = https://github.com/Cevelop/cevelop.github.io/raw/master/img/logo-square-48.png
+ source = https://github.com/Cevelop/cevelop.github.io/raw/master/img/logo-square-256.png
+ source = https://github.com/Cevelop/cevelop.github.io/raw/master/img/logo-square.svg
+ sha256sums = 640fd01c6ca0b8d817140e441e47a6949406a67dae3abc96ef8cba22153573d6
+ sha256sums = 578aea66235898a6f6d25420f5251b4df0e2a08be4302d9ab2a9e7e54359cb1b
+ sha256sums = e88728544af4f6924784cb2885f3d86d4bd5cceb918f8fc552126b3f93288830
+ sha256sums = 7c31396b3facdf0a5ff57e2ee8a5ea0ff741955048e34116d4296ffa35e74218
+ sha256sums = 98ab055ecde507b6603743ab40db3dfdb6d6b3b24cb5fff244982ae641d865a0
+ sha256sums = d99f2f3b58aef682fcab7d1cedf20fc4fc44152c6b964af49212a9e7f4d35def
+ sha256sums = ebd2b54d0487de845093cabda98d5e0977f436fc10d40f15d2cb1598084222e4
+ source_i686 = https://www.cevelop.com/cevelop/downloads/cevelop-1.4.0-201512021228-linux.gtk.x86.tar.gz
+ sha256sums_i686 = 4e47ed3004af209d130540a26877067372b849d922f503cd6a9f0dbb3f84a761
+ source_x86_64 = https://www.cevelop.com/cevelop/downloads/cevelop-1.4.0-201512021228-linux.gtk.x86_64.tar.gz
+ sha256sums_x86_64 = c08a3781e2f6573f47a74a9d8cbc27e35755d3e3203eeb103ad93d05a7b4a7e8
+
+pkgname = cevelop
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..fa5f7446d2de
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,61 @@
+LICENSE
+
+
+This is a legal agreement between you, the end user, and Hochschule für
+Technik Rapperswil HSR, hereinafter referred to as "HSR". Cevelop (the
+"Software") is owned by HSR and is protected by copyright law. Upon
+acceptance of the terms of this License Agreement, your rights and
+obligations with respect to use of the Software are as follows.
+
+
+COPYRIGHT
+
+The Software and Documentation are copyrighted by HSR and are protected
+by international copyright laws. The product contains copyrighted
+software of HSR. All rights reserved. You agree not to remove any
+trademarks or copyright notices from the Software or Documentation.
+
+
+OTHER RESTRICTIONS
+
+You may not disclose, publish, translate, rent, lease, transfer, export
+or otherwise make the Software available in any form, to any person or
+entity, except as expressly licensed herein. You may not reverse
+engineer, decompile or disassemble the Software.
+
+You cannot use HSR or related names, logos or trademarks to market your
+software without express written permission.
+
+IN NO EVENT SHALL HSR BE LIABLE FOR ANY LOSS OF PROFIT OR ANY OTHER
+DAMAGE, INCLUDING BUT NOT LIMITED TO SPECIAL, INCIDENTAL, CONSEQUENTIAL
+OR OTHER DAMAGES. THE SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF
+ANY KIND. HSR SPECIFICALLY DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR
+IMPLIED, INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OF
+MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE.
+
+HSR DOES NOT WARRANT THAT THE SOFTWARE WILL MEET YOUR REQUIREMENTS OR
+THAT THE OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE.
+
+
+GOVERNING LAW
+
+This Agreement shall be governed by Swiss law, without regard to
+conflict of laws principles. This Agreement may only be modified by a
+written document signed by the party or parties to be bound. Except as
+may be specified in such a written agreement, this is the entire
+agreement between you and HSR and all other terms are rejected. You
+agree not to use, ship, or export the Software in violation of any
+applicable law.
+
+In the event of any legal disputes in conjunction with this license and
+contracts based on it, the courts of Rapperswil/SG shall be the sole
+competent courts.
+
+
+ENTIRE AGREEMENT
+
+You agree that this Agreement expresses the entire understanding between
+you and HSR, and supersedes all other communications, oral or written,
+relating to the Software.
+
+© 2014 Hochschule für Technik Rapperswil
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d6882caa802
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Marcel Huber <marcelhuberfoo@gmail.com>
+
+pkgname=cevelop
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="The C++ IDE for professional developers"
+license=('custom')
+arch=('i686' 'x86_64')
+url='https://www.cevelop.com'
+makedepends=(gendesk libarchive)
+depends=(java-environment webkitgtk2 unzip "glibc>2.14" python)
+optdepends=('hicolor-icon-theme')
+provides=('cevelop')
+install=${pkgname}.install
+source=(cevelop.sh
+ LICENSE
+ https://github.com/Cevelop/cevelop.github.io/raw/master/img/logo-square-{16,32,48,256}.png
+ https://github.com/Cevelop/cevelop.github.io/raw/master/img/logo-square.svg)
+source_i686=(https://www.cevelop.com/cevelop/downloads/cevelop-1.4.0-201512021228-linux.gtk.x86.tar.gz)
+source_x86_64=(https://www.cevelop.com/cevelop/downloads/cevelop-1.4.0-201512021228-linux.gtk.x86_64.tar.gz)
+sha256sums=('640fd01c6ca0b8d817140e441e47a6949406a67dae3abc96ef8cba22153573d6'
+ '578aea66235898a6f6d25420f5251b4df0e2a08be4302d9ab2a9e7e54359cb1b'
+ 'e88728544af4f6924784cb2885f3d86d4bd5cceb918f8fc552126b3f93288830'
+ '7c31396b3facdf0a5ff57e2ee8a5ea0ff741955048e34116d4296ffa35e74218'
+ '98ab055ecde507b6603743ab40db3dfdb6d6b3b24cb5fff244982ae641d865a0'
+ 'd99f2f3b58aef682fcab7d1cedf20fc4fc44152c6b964af49212a9e7f4d35def'
+ 'ebd2b54d0487de845093cabda98d5e0977f436fc10d40f15d2cb1598084222e4')
+sha256sums_i686=('4e47ed3004af209d130540a26877067372b849d922f503cd6a9f0dbb3f84a761')
+sha256sums_x86_64=('c08a3781e2f6573f47a74a9d8cbc27e35755d3e3203eeb103ad93d05a7b4a7e8')
+
+prepare() {
+ gendesk -n --pkgname "$pkgname" \
+ --pkgdesc "Cevelop C++ IDE" --categories "Application;Development;IDE"
+}
+
+package() {
+ cd $srcdir
+ install -m755 -d $pkgdir/usr/{bin,share/applications,share/licences/,lib/$pkgname}
+ install -m755 -d $pkgdir/usr/share/icons/hicolor/{16x16,32x32,48x48,256x256,scalable}/apps
+ bsdtar cf - --cd $pkgname-$pkgver \
+ --exclude ./lib*.so.* \
+ --exclude ./icon.xpm \
+ --exclude ./detect-libc \
+ --exclude ./cevelop.desktop \
+ --exclude ./cevelop.sh . | bsdtar xf - --cd $pkgdir/usr/lib/$pkgname/
+ install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$pkgname-$pkgver/icon.xpm" "$pkgdir/usr/share/pixmaps/$pkgname.xpm"
+ for _i in 16 32 48 256; do
+ install -Dm644 $srcdir/logo-square-${_i}.png \
+ "$pkgdir/usr/share/icons/hicolor/${_i}x${_i}/apps/${pkgname}.png"
+ done
+ install -Dm644 $srcdir/logo-square.svg \
+ "$pkgdir/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: set ft=sh syn=sh ts=2 sw=2 et:
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..757c43f6cad0
--- /dev/null
+++ b/README.md
@@ -0,0 +1,6 @@
+arch-cevelop
+============
+
+ ArchLinux PKGBUILD for Cevelop C++ IDE from https://cevelop.com/
+
+ The package source build is submitted to AUR at: https://aur.archlinux.org/packages/cevelop/
diff --git a/cevelop.install b/cevelop.install
new file mode 100644
index 000000000000..a2930a4ff27b
--- /dev/null
+++ b/cevelop.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/cevelop.sh b/cevelop.sh
new file mode 100755
index 000000000000..b159fb6afa12
--- /dev/null
+++ b/cevelop.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# Disable GTK3 because it seems to cause more problems and has no benefits for now
+export SWT_GTK3=0
+
+export ECLIPSE_HOME=/usr/lib/cevelop
+exec "$ECLIPSE_HOME/runner" "$@"