summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--adjust-libclang-lib-names.patch18
3 files changed, 32 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe63f96ce77f..a5bc4a59ee66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cgrep-clang-git
pkgdesc = grep for C/C++ source files
- pkgver = r143.a6c42a8
- pkgrel = 2
+ pkgver = r154.f7e9ac8
+ pkgrel = 1
url = https://github.com/bloodstalker/cgrep
arch = any
license = GPL3
@@ -12,8 +12,10 @@ pkgbase = cgrep-clang-git
conflicts = cgrep-clang
source = cgrep-clang::git+https://github.com/bloodstalker/cgrep
source = git+https://github.com/bloodstalker/cfe-extra
+ source = adjust-libclang-lib-names.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = c726ccfdc45f9ad434647cfcab95ac536700ab87978f05f3a341a555642eb8c4
pkgname = cgrep-clang-git
diff --git a/PKGBUILD b/PKGBUILD
index 798a099216af..258a5eff1fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,21 @@
_name=cgrep-clang
pkgname=$_name-git
-pkgver=r143.a6c42a8
+pkgver=r154.f7e9ac8
_mainfolder=$_name
-pkgrel=2
+pkgrel=1
pkgdesc='grep for C/C++ source files'
arch=(any)
url=https://github.com/bloodstalker/cgrep
license=(GPL3)
depends=(llvm clang)
makedepends=(git)
-source=($_name::git+$url git+https://github.com/bloodstalker/cfe-extra)
+source=($_name::git+$url
+ git+https://github.com/bloodstalker/cfe-extra
+ adjust-libclang-lib-names.patch)
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'c726ccfdc45f9ad434647cfcab95ac536700ab87978f05f3a341a555642eb8c4')
conflicts=($_name)
provides=($_name)
@@ -40,6 +43,9 @@ prepare() {
package() {
cd "$srcdir/$_mainfolder"
+ # see https://www.archlinux.org/todo/llvm-10/
+ patch -p1 -i "$srcdir/adjust-libclang-lib-names.patch"
+
make
# `make install` isn't provided, so we have to manually copy the files
diff --git a/adjust-libclang-lib-names.patch b/adjust-libclang-lib-names.patch
new file mode 100644
index 000000000000..358f5b361973
--- /dev/null
+++ b/adjust-libclang-lib-names.patch
@@ -0,0 +1,18 @@
+diff --git a/makefile b/makefile
+index 94fd556..35483c2 100644
+--- a/makefile
++++ b/makefile
+@@ -38,12 +38,7 @@ LLVM_CXX_FLAGS=$(shell $(LLVM_CONF) --cxxflags)
+ LLVM_CXX_FLAGS+=-I$(shell $(LLVM_CONF) --src-root)/tools/clang/include\
+ -I$(shell $(LLVM_CONF) --obj-root)/tools/clang/include\
+ -std=c++17 -fexceptions
+-LLVM_LD_FLAGS=-Wl,--start-group -lclangAST -lclangAnalysis -lclangBasic\
+- -lclangDriver -lclangEdit -lclangFrontend -lclangFrontendTool\
+- -lclangLex -lclangParse -lclangSema -lclangEdit -lclangASTMatchers\
+- -lclangRewrite -lclangRewriteFrontend -lclangStaticAnalyzerFrontend\
+- -lclangStaticAnalyzerCheckers -lclangStaticAnalyzerCore\
+- -lclangSerialization -lclangToolingCore -lclangTooling -lstdc++\
++LLVM_LD_FLAGS=-Wl,--start-group -lclang-cpp -lstdc++\
+ -lLLVMRuntimeDyld -lm -Wl,--end-group
+ LLVM_LD_FLAGS+=$(shell $(LLVM_CONF) --ldflags --libs --system-libs)
+