summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--Makefile13
-rw-r--r--PKGBUILD6
3 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2af178f6d3d..314dfb733b0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = chatterino2-appimage
pkgdesc = Second installment of the Twitch chat client series "Chatterino", release appimage
- pkgver = 2.3.4
+ pkgver = 2.5.1
pkgrel = 1
url = https://chatterino.com
install = chatterino2-appimage.install
arch = x86_64
license = MIT
- depends = qt5-multimedia
- depends = qt5-base
- depends = qt5-tools
- depends = boost-libs
- depends = openssl
+ depends = fuse2
optdepends = streamlink: For piping streams to video players
optdepends = pulseaudio: For audio output
optdepends = gst-plugins-good: For audio output
provides = chatterino
conflicts = chatterino
options = !strip
- source = https://github.com/Chatterino/chatterino2/releases/download/v2.3.4/Chatterino-x86_64.AppImage
- md5sums = 0368a12c38f96385269760af24f4e80b
+ source = https://github.com/Chatterino/chatterino2/releases/download/v2.5.1/Chatterino-x86_64.AppImage
+ sha256sums = cd58cb216f6d82be617e5a2cfaa646b28093af97c1448cf8a584aa82b2c25383
pkgname = chatterino2-appimage
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..0e702b7ca026
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,13 @@
+.PHONY: all
+
+all: clean rebuild srcinfo
+
+rebuild:
+ updpkgsums
+ makepkg -s
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf pkg src chatterino2-appimage-*.tar.* *.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index f2c73e9f9b6b..b02f32bb90f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@ _pkgname=chatterino
_appimage=Chatterino-x86_64.AppImage
pkgname=chatterino2-appimage
-pkgver=2.3.4
+pkgver=2.5.1
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", release appimage'
arch=('x86_64')
url=https://chatterino.com
license=('MIT')
-depends=('qt5-multimedia' 'qt5-base' 'qt5-tools' 'boost-libs' 'openssl')
+depends=('fuse2')
optdepends=('streamlink: For piping streams to video players'
'pulseaudio: For audio output'
'gst-plugins-good: For audio output')
@@ -18,7 +18,7 @@ conflicts=('chatterino')
options=(!strip)
install=$pkgname.install
source=("https://github.com/Chatterino/chatterino2/releases/download/v$pkgver/$_appimage")
-md5sums=('0368a12c38f96385269760af24f4e80b')
+sha256sums=('cd58cb216f6d82be617e5a2cfaa646b28093af97c1448cf8a584aa82b2c25383')
prepare () {
cd "$srcdir"