summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile2
-rw-r--r--PKGBUILD9
3 files changed, 15 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fb4bc7c0527..42682526410f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Second installment of the Twitch chat client series "Chatterino", dev/git version
- pkgver = 2.5.0.r3.g4a1ce2a
+ pkgver = 2.5.1.r47.gd053a68
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
@@ -32,6 +32,8 @@ pkgbase = chatterino2-git
source = git+https://github.com/zaphoyd/websocketpp
source = git+https://github.com/Neargye/magic_enum
source = git+https://github.com/mackron/miniaudio
+ source = git+https://github.com/lua/lua
+ source = git+https://github.com/martinmoene/expected-lite
source = git+https://github.com/Chatterino/crash-handler
md5sums = SKIP
md5sums = SKIP
@@ -44,5 +46,7 @@ pkgbase = chatterino2-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = chatterino2-git
diff --git a/Makefile b/Makefile
index 0e3e851b824f..69cb7858b37c 100644
--- a/Makefile
+++ b/Makefile
@@ -36,4 +36,6 @@ clean:
sanitizers-cmake \
websocketpp \
magic_enum \
+ lua \
+ expected-lite \
miniaudio
diff --git a/PKGBUILD b/PKGBUILD
index 5ed9430ec24e..a2f10e9b4f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ckat <ckat@teknik.io>
pkgname=chatterino2-git
_pkgname=chatterino2
-pkgver=2.5.0.r3.g4a1ce2a
+pkgver=2.5.1.r47.gd053a68
pkgrel=1
pkgdesc='Second installment of the Twitch chat client series "Chatterino", dev/git version'
arch=('any')
@@ -24,6 +24,8 @@ source=("git+https://github.com/Chatterino/chatterino2"
"git+https://github.com/zaphoyd/websocketpp"
"git+https://github.com/Neargye/magic_enum"
"git+https://github.com/mackron/miniaudio"
+ "git+https://github.com/lua/lua"
+ "git+https://github.com/martinmoene/expected-lite"
"git+https://github.com/Chatterino/crash-handler")
md5sums=('SKIP'
'SKIP'
@@ -35,6 +37,8 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
# We temporarily disable LTO since we get an ICE when compiling with gcc since this commit https://github.com/Chatterino/chatterino2/commit/ed20e71db4c957d3b2a8ce9350b847f4c805cb83
# Bug report tracking https://gcc.gnu.org/bugzilla/show_bug.cgi?id=114501
@@ -57,6 +61,8 @@ prepare () {
git config submodule.lib/websocketpp.url "$srcdir/websocketpp"
git config submodule.lib/miniaudio.url "$srcdir/miniaudio"
git config submodule.lib/magicenum.url "$srcdir/magicenum"
+ git config submodule.lib/lua/src.url "$srcdir/lua"
+ git config submodule.lib/expected-lite.url "$srcdir/expected-lite"
git config submodule.tools/crash-handler.url "$srcdir/crash-handler"
git -c protocol.file.allow=always submodule update
}
@@ -75,6 +81,7 @@ build() {
-DUSE_PRECOMPILED_HEADERS=OFF \
-DBUILD_WITH_QT6=ON \
-DCHATTERINO_UPDATER=OFF \
+ -DCHATTERINO_PLUGINS=ON \
"${flags[@]}" \
..
cmake --build .