summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f8ea1cb5327..d2ee069ab388 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chatterino2-git
pkgdesc = Chatterino 2 is the second installment of the Twitch chat client series "Chatterino". dev/git version.
- pkgver = nightly.win.r39.ge23ce31
+ pkgver = r1503.8bcc9c48
pkgrel = 1
url = https://chatterino.com
install = chatterino2-git.install
@@ -15,6 +15,7 @@ pkgbase = chatterino2-git
depends = qt5-base
depends = qt5-svg
depends = pulseaudio
+ optdepends = streamlink: For piping streams to video players
provides = chatterino
conflicts = chatterino
source = chatterino.png
diff --git a/PKGBUILD b/PKGBUILD
index 065476396443..95317b00da2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=chatterino2
pkgname="$_name-git"
-pkgver=nightly.win.r39.ge23ce31
+pkgver=r1503.8bcc9c48
pkgrel=1
pkgdesc='Chatterino 2 is the second installment of the Twitch chat client series "Chatterino". dev/git version.'
arch=('any')
@@ -12,16 +12,14 @@ install=$pkgname.install
provides=("${_name%2}")
conflicts=("${_name%2}")
depends=('rapidjson' 'gst-plugins-ugly' 'gst-plugins-good' 'qt5-multimedia' 'qt5-base' 'qt5-svg' 'pulseaudio')
+optdepends=('streamlink: For piping streams to video players')
makedepends=('boost' 'git')
source=("${_name%2}.png" "${_name%2}.desktop" "git://github.com/fourtf/$_name")
sha1sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_name"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare () {