summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cd62952a44e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = chdig-latest-bin
+ pkgdesc = Dig into ClickHouse with TUI interface (compiled binaries for upstream)
+ pkgver = 0.4.0.32.g0d80c8c.1
+ pkgrel = 1
+ url = https://github.com/azat/chdig
+ arch = x86_64
+ license = MIT
+ provides = chdig
+ conflicts = chdig
+ source = https://github.com/azat/chdig/releases/download/latest/chdig-latest-x86_64.pkg.tar.zst
+ sha256sums = SKIP
+
+pkgname = chdig-latest-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71b946231dfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# shellcheck disable=SC2034,SC2154
+# - SC2034 - appears unused.
+# - SC2154 - pkgdir is referenced but not assigned.
+
+# Maintainer: Azat Khuzhin <a3at.mail@gmail.com>
+pkgname=chdig-latest-bin
+pkgver=0.4.0.32.g0d80c8c.1
+pkgrel=1
+pkgdesc="Dig into ClickHouse with TUI interface (compiled binaries for upstream)"
+arch=('x86_64')
+conflicts=("chdig")
+provides=("chdig")
+url="https://github.com/azat/chdig"
+license=('MIT')
+source=(
+ "https://github.com/azat/chdig/releases/download/latest/chdig-latest-x86_64.pkg.tar.zst"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+# Rewrite version from latest to the real one
+pkgver() {
+ tar -xf chdig-latest-x86_64.pkg.tar.zst -O .PKGINFO | awk '/pkgver/ { print $NF }' | sed -e 's/-/./g'
+}
+
+package() {
+ tar -C "$pkgdir" -xvf chdig-latest-x86_64.pkg.tar.zst
+ rm -f "$pkgdir/.PKGINFO"
+ rm -f "$pkgdir/.MTREE"
+}
+# vim set: ts=4 sw=4 et