summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1964b4763e12..7c835b2afdf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 30 08:07:20 UTC 2017
+# Mon Jun 18 14:13:32 UTC 2018
pkgbase = cheat-git
pkgdesc = Cheat allows you to create and view interactive cheatsheets on the command-line
- pkgver = 2.2.0
+ pkgver = 2.2.3
pkgrel = 1
url = https://github.com/chrisallenlane/cheat
arch = any
@@ -10,7 +10,8 @@ pkgbase = cheat-git
makedepends = git
depends = python2
depends = python2-docopt
- optdepends = python-pygments
+ optdepends = python2-pygments
+ optdepends = bash-completion
source = cheat-git::git+https://github.com/chrisallenlane/cheat.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d0203f05e084..fb6ec4ee59b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Maintainer: Quan Guo < guotsuan@gmail.com>
pkgname=cheat-git
-pkgver=2.2.0
+pkgver=2.2.3
pkgrel=1
pkgdesc="Cheat allows you to create and view interactive cheatsheets on the command-line"
arch=('any')
license=('GPL3')
url="https://github.com/chrisallenlane/cheat"
depends=('python2' 'python2-docopt')
-optdepends=('python-pygments')
+optdepends=('python2-pygments' 'bash-completion')
makedepends=('git')
source=("$pkgname::git+https://github.com/chrisallenlane/cheat.git")
md5sums=('SKIP')
@@ -24,4 +24,6 @@ pkgver() {
package(){
cd "$pkgname"
python2 setup.py install --root=$pkgdir
+ install -dm755 ${pkgdir}/usr/share/bash-completion/completions/
+ install -m 644 ${srcdir}/$pkgname/cheat/autocompletion/cheat.bash $pkgdir/usr/share/bash-completion/completions/
}