summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD7
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fe1a9061dbe..cd6c6739b539 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = check50
pkgdesc = This is check50, with which you can check solutions to problems for CS50.
- pkgver = 2.2.6
+ pkgver = 3.3.3
pkgrel = 1
url = https://github.com/cs50/check50
arch = any
+ groups = cs50
license = GPL
makedepends = python-setuptools
- depends = python
- depends = submit50
- source = https://files.pythonhosted.org/packages/source/c/check50/check50-2.2.6.tar.gz
- sha256sums = c3430446de5f03a9016d1bb45a09ebe5577d03d386c58b7a5e560d6299a222c7
+ depends = lib50
+ depends = python-beautifulsoup4
+ depends = python-pyaml
+ depends = python-jinja
+ source = https://files.pythonhosted.org/packages/source/c/check50/check50-3.3.3.tar.gz
+ sha256sums = 61995f43be54d6c90ad60fb81196dab9a1f2d283b6470bf1fac6e5cd43ba002d
pkgname = check50
- depends = python
- depends = submit50
-
+ depends = lib50
+ depends = python-beautifulsoup4
+ depends = python-pyaml
+ depends = python-jinja
diff --git a/PKGBUILD b/PKGBUILD
index e347f07061d4..03420e431fd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,20 @@
pkgname=check50
_module='check50' # PyPI specific
-pkgver=2.2.6
+pkgver=3.3.3
pkgrel=1
pkgdesc="This is check50, with which you can check solutions to problems for CS50."
arch=('any')
url="https://github.com/cs50/check50"
license=('GPL')
-depends=('python' 'submit50')
+groups=('cs50');
+depends=('lib50' 'python-beautifulsoup4' 'python-pyaml' 'python-jinja')
makedepends=('python-setuptools')
source=(
"https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
)
sha256sums=(
- 'c3430446de5f03a9016d1bb45a09ebe5577d03d386c58b7a5e560d6299a222c7'
+ '61995f43be54d6c90ad60fb81196dab9a1f2d283b6470bf1fac6e5cd43ba002d'
)
build() {