summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--chemtool.desktop13
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d51aa46c1df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chemtool
+ pkgdesc = A small program for drawing chemical structures
+ pkgver = 1.6.14
+ pkgrel = 4
+ url = http://ruby.chemie.uni-freiburg.de/~martin/chemtool/chemtool.html
+ arch = x86_64
+ license = GPL2
+ depends = gtk2
+ depends = desktop-file-utils
+ source = http://ruby.chemie.uni-freiburg.de/~martin/chemtool/chemtool-1.6.14.tar.gz
+ source = chemtool.desktop
+ md5sums = 3a97680f0abe1327af1f0072551a68e2
+ md5sums = 8cbb6f7021bd5aaa6f6a31fc4d95a06e
+
+pkgname = chemtool
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48719e662ef3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+#Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=chemtool
+pkgver=1.6.14
+pkgrel=4
+pkgdesc="A small program for drawing chemical structures"
+arch=(x86_64)
+license=('GPL2')
+url="http://ruby.chemie.uni-freiburg.de/~martin/chemtool/chemtool.html"
+depends=('gtk2' 'desktop-file-utils')
+source=(http://ruby.chemie.uni-freiburg.de/~martin/${pkgname}/${pkgname}-${pkgver}.tar.gz chemtool.desktop)
+
+build() {
+ cd ${pkgname}-${pkgver}
+ CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}/" install
+ install -D -m644 gnome/chemtool.png "${pkgdir}"/usr/share/pixmaps/chemtool.png
+ install -D -m644 "${srcdir}"/chemtool.desktop "${pkgdir}"/usr/share/applications/chemtool.desktop
+}
+md5sums=('3a97680f0abe1327af1f0072551a68e2'
+ '8cbb6f7021bd5aaa6f6a31fc4d95a06e')
diff --git a/chemtool.desktop b/chemtool.desktop
new file mode 100644
index 000000000000..a93770aea04e
--- /dev/null
+++ b/chemtool.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Chemtool
+Comment=Molecules 2D drawing
+Name[cs_CZ.ISO8859-2]=Chemtool
+Comment[cs_CZ.ISO8859-2]=Editor molekul
+Comment[de_DE.ISO8859-1]=Moleküleditor
+Exec=chemtool
+Icon=chemtool.png
+Terminal=false
+MultipleArgs=false
+Type=Application
+Categories=Application;Graphics;2DGraphics;GTK;
+MimeType=application/x-chemtool;