summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
-rw-r--r--chess.com.desktop8
-rw-r--r--chess.com.pngbin0 -> 13649 bytes
-rw-r--r--no-scrollbar.css3
5 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2d69cda52cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = chess.com
+ pkgdesc = Electron wrapper for Chess.com chess platform
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.chess.com/
+ arch = x86_64
+ license = GNU AGPL
+ makedepends = nodejs
+ makedepends = nodejs-nativefier
+ makedepends = npm
+ provides = chess.com
+ conflicts = chess.com
+ source = chess.com.png
+ source = chess.com.desktop
+ source = no-scrollbar.css
+ sha256sums = 3aaf53d144cc6383bc614aa0b538218f187c9d299024a57884c013a55e869e4f
+ sha256sums = d55d600b9fca9a6d29ac9f49088e72ad40fdeff81a22de278145c597f9dc2421
+ sha256sums = 65f4043f2206e43cbbc510246f6a35a673e829bd8ab5b90b790b1ba7c14ea26b
+
+pkgname = chess.com
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21b5a0b502eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Alexis Potelle <alexispotelle at gmail dot com>
+
+_instname=chess.com
+pkgname=chess.com
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Electron wrapper for Chess.com chess platform"
+arch=('x86_64')
+url=https://www.chess.com/
+license=('GNU AGPL')
+groups=()
+depends=()
+makedepends=(nodejs nodejs-nativefier npm)
+provides=($pkgname)
+conflicts=($pkgname)
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname.png"
+ "$pkgname.desktop"
+ "no-scrollbar.css")
+sha256sums=('3aaf53d144cc6383bc614aa0b538218f187c9d299024a57884c013a55e869e4f'
+ 'd55d600b9fca9a6d29ac9f49088e72ad40fdeff81a22de278145c597f9dc2421'
+ '65f4043f2206e43cbbc510246f6a35a673e829bd8ab5b90b790b1ba7c14ea26b')
+
+
+build() {
+ nativefier $url \
+ --icon $pkgname.png \
+ --name $_instname \
+ --user-agent "Mozilla/5.0 (X11; Linux ${CARCH};) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/114.0.5735.133 Safari/537.36"\
+ --inject no-scrollbar.css\
+ --internal-urls "(.*?chess\.com.*?)" \
+ --single-instance \
+ --tray
+
+}
+
+package() {
+ install -d "$pkgdir"/opt "$pkgdir"/usr/{bin,share/pixmaps}
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$_instname.desktop
+
+ cp -rL $_instname-linux-* "$pkgdir"/opt/$pkgname
+ ln -sf /opt/$pkgname/$_instname "$pkgdir"/usr/bin/$_instname
+ cp $srcdir/$pkgname.png "$pkgdir"/usr/share/pixmaps/$_instname.png
+
+ chmod 666 "$pkgdir"/opt/$pkgname/resources/app/nativefier.json
+}
+
diff --git a/chess.com.desktop b/chess.com.desktop
new file mode 100644
index 000000000000..3c8ff6c8c488
--- /dev/null
+++ b/chess.com.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Ches.com
+Comment=Play chess on Chess.com
+Exec=chess.com
+Icon=chess.com
+Terminal=false
+Categories=Game;Chess;Nativefier;
diff --git a/chess.com.png b/chess.com.png
new file mode 100644
index 000000000000..fcbe8b0b223f
--- /dev/null
+++ b/chess.com.png
Binary files differ
diff --git a/no-scrollbar.css b/no-scrollbar.css
new file mode 100644
index 000000000000..85df2e70e284
--- /dev/null
+++ b/no-scrollbar.css
@@ -0,0 +1,3 @@
+::-webkit-scrollbar {
+ display: none;
+}