summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98cadbaa5c85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chicken-apropos
+ pkgdesc = Chicken Scheme apropos
+ pkgver = 3.8.3
+ pkgrel = 1
+ url = http://wiki.call-cc.org/eggref/5/apropos
+ arch = x86_64
+ license = BSD
+ depends = chicken
+ depends = chicken-srfi-1
+ depends = chicken-utf8
+ depends = chicken-string-utils
+ depends = chicken-symbol-utils
+ depends = chicken-check-errors>=3.4.0
+
+pkgname = chicken-apropos
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eefa555fe313
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=chicken-apropos
+_name=apropos
+pkgver=3.8.3
+pkgrel=1
+pkgdesc='Chicken Scheme apropos'
+arch=('x86_64')
+license=('BSD')
+depends=("chicken" "chicken-srfi-1" "chicken-utf8" "chicken-string-utils" "chicken-symbol-utils" "chicken-check-errors>=3.4.0")
+url='http://wiki.call-cc.org/eggref/5/apropos'
+
+build() {
+ CHICKEN_INSTALL_REPOSITORY=${srcdir} CHICKEN_INSTALL_PREFIX=${srcdir} chicken-install -no-install-dependencies $_name:$pkgver
+}
+package() {
+ install -d ${pkgdir}/usr/lib/chicken/11
+ find ${srcdir} -maxdepth 1 -type f -exec cp -t ${pkgdir}/usr/lib/chicken/11 {} +
+}
+