summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d8ccc6cb7985
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = chicken-setup-helper
+ pkgdesc = Chicken Scheme Egg: Installation/Setup Shortcut Routines
+ pkgver = 1.5.5
+ pkgrel = 1
+ url = http://chicken.wiki.br/eggref/4/setup-helper
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = chicken>=4.5.0
+ options = docs
+ options = !libtool
+ options = !emptydirs
+
+pkgname = chicken-setup-helper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cccc291fc183
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jim Pryor <profjim@jimpryor.net>
+# Maintainer: perlawk
+
+pkgname=chicken-setup-helper
+_pkgname=setup-helper
+pkgver=1.5.5
+pkgrel=1
+pkgdesc="Chicken Scheme Egg: Installation/Setup Shortcut Routines"
+arch=('i686' 'x86_64')
+url="http://chicken.wiki.br/eggref/4/setup-helper"
+license=('BSD')
+depends=('chicken>=4.5.0' )
+options=(docs !libtool !emptydirs)
+
+build() {
+ cd "$srcdir/"
+ chicken-install -r "$_pkgname"
+}
+
+package() {
+ cd "$_pkgname"
+ chicken-install -p "$pkgdir/usr"
+}