summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--chruby-fish.install22
-rw-r--r--chruby-root.patch22
4 files changed, 14 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8a6dd3bd8db..d4f88b331610 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = chruby-fish
- pkgdesc = Thin wrapper around chruby to make it work with the Fish shell
- pkgver = 0.8.2
+ pkgdesc = A compatible implementation of chruby for the Fish shell
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/JeanMertz/chruby-fish
install = chruby-fish.install
arch = any
license = MIT
- depends = chruby
depends = fish
- source = https://github.com/JeanMertz/chruby-fish/archive/v0.8.2.tar.gz
- source = chruby-root.patch
- sha256sums = e3726d39da219f5339f86302f7b5d7b62ca96570ddfcc3976595f1d62e3b34e1
- sha256sums = a2f186f1dd1e7adc62d8315617443e0771f5d5ff7c3dee9794bcf0327c2d33fd
+ source = https://github.com/JeanMertz/chruby-fish/archive/v1.0.0.tar.gz
+ sha256sums = db1023255fa55c9a01b06404cd394cccf790d42985cf85706211e5a0dda4fd9f
pkgname = chruby-fish
-
diff --git a/PKGBUILD b/PKGBUILD
index 88d1465524c3..2a2f2cb1cfdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,17 @@
# Maintainer: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=chruby-fish
-pkgver=0.8.2
+pkgver=1.0.0
pkgrel=1
-pkgdesc="Thin wrapper around chruby to make it work with the Fish shell"
+pkgdesc="A compatible implementation of chruby for the Fish shell"
arch=(any)
url="https://github.com/JeanMertz/chruby-fish"
license=('MIT')
-depends=('chruby' 'fish')
+depends=('fish')
install=${pkgname}.install
-source=("https://github.com/JeanMertz/chruby-fish/archive/v${pkgver}.tar.gz"
- chruby-root.patch)
-sha256sums=('e3726d39da219f5339f86302f7b5d7b62ca96570ddfcc3976595f1d62e3b34e1'
- 'a2f186f1dd1e7adc62d8315617443e0771f5d5ff7c3dee9794bcf0327c2d33fd')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p0 -i ../chruby-root.patch
-}
+source=("https://github.com/JeanMertz/chruby-fish/archive/v${pkgver}.tar.gz")
+sha256sums=('db1023255fa55c9a01b06404cd394cccf790d42985cf85706211e5a0dda4fd9f')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/chruby-fish.install b/chruby-fish.install
index 9ac8c5e328b0..38564ce8950f 100644
--- a/chruby-fish.install
+++ b/chruby-fish.install
@@ -1,21 +1,9 @@
-post_install() {
- echo "
-Add the following line to your config.fish file:
- source /usr/share/chruby/chruby.fish
-To enable auto-switching, also add the auto.fish file:
- source /usr/share/chruby/auto.fish
-"
-}
-
post_upgrade() {
- post_install
-}
-
-post_remove() {
echo "
-Please do not forget to delete the following line from your config.fish file:
- source /usr/share/chruby/chruby.fish
-If auto-switching is enabled, also delete the following line:
- source /usr/share/chruby/auto.fish
+chruby-fish no longer depends on chruby and is loaded automatically.
+
+You can remove chruby if you don't need it, and you should remove any source
+references from your config.fish file as chruby-fish automatically registers
+itself.
"
}
diff --git a/chruby-root.patch b/chruby-root.patch
deleted file mode 100644
index 0ca4355411aa..000000000000
--- a/chruby-root.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- share/chruby/auto.fish.orig 2018-11-07 15:58:27.159444234 +0800
-+++ share/chruby/auto.fish 2018-11-07 15:58:54.980122739 +0800
-@@ -35,7 +35,7 @@
- # `chruby.sh` and `auto.sh` are located in a custom path.
- #
- function chruby_auto -e fish_prompt
-- set -q CHRUBY_ROOT; or set CHRUBY_ROOT /usr/local
-+ set -q CHRUBY_ROOT; or set CHRUBY_ROOT /usr
-
- #
- # line 1: source official `chruby.sh` file.
---- share/chruby/chruby.fish.orig 2018-11-07 15:58:32.042896698 +0800
-+++ share/chruby/chruby.fish 2018-11-07 15:59:21.780775961 +0800
-@@ -34,7 +34,7 @@
- # `chruby.sh` is located in a custom path.
- #
- function bchruby
-- set -q CHRUBY_ROOT; or set CHRUBY_ROOT /usr/local
-+ set -q CHRUBY_ROOT; or set CHRUBY_ROOT /usr
-
- if test ! -f "$CHRUBY_ROOT/share/chruby/chruby.sh";
- echo "$CHRUBY_ROOT/share/chruby/chruby.sh does not exist." \