summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5ee054d0e30..26b0490e7eee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ciphey
pkgdesc = Automated decryption tool
pkgver = 5.14.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/Ciphey/Ciphey
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index e4f9e87513be..48c10eea2bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Nagy Roland <roliboy@protonmail.com>
+# Maintainer: pusi77 <pusineriandrea+gmail+com>
pkgname=ciphey
pkgver=5.14.0
-pkgrel=6
+pkgrel=7
pkgdesc="Automated decryption tool"
arch=("any")
url="https://github.com/Ciphey/Ciphey"
@@ -16,8 +16,8 @@ depends=(
"python-click"
"python-loguru" #aur
"python-mock"
- "python-cipheycore"
- "python-cipheydists"
+ "python-cipheycore" #aur
+ "python-cipheydists" #aur
"python-pyaml"
"python-pybase62" #aur
"python-pylint"
@@ -35,10 +35,8 @@ source=(
"$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
"what.py.patch"
)
-sha256sums=(
- "42fd5ea5b462ab37cb2e6aed41c254e7ed44bb190fed9a3918e6bdd56d86e10f"
- "720914463a9004a78ee685a2124c1b1d915609705ef84b1cafdf448d7c796198"
-)
+sha256sums=('42fd5ea5b462ab37cb2e6aed41c254e7ed44bb190fed9a3918e6bdd56d86e10f'
+ '720914463a9004a78ee685a2124c1b1d915609705ef84b1cafdf448d7c796198')
build() {
cd "$srcdir/Ciphey-$pkgver"
@@ -46,16 +44,11 @@ build() {
patch "what.py" < "$srcdir/what.py.patch"
cd "$srcdir/Ciphey-$pkgver"
- poetry build
-
- cd dist
- tar xf "ciphey-$pkgver.tar.gz"
- cd "ciphey-$pkgver"
- python setup.py build
+ python -m build --wheel
}
package() {
- cd "$srcdir/Ciphey-$pkgver/dist/ciphey-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "Ciphey-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 "$srcdir/Ciphey-$pkgver/license" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}