summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d0a34ae26ee..74ddf709e779 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r9594.54c499ed5
+ pkgver = r9621.89663e0db
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -57,6 +57,7 @@ pkgbase = citra-git
source = vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git
source = git+https://github.com/KhronosGroup/SPIRV-Headers.git
source = git+https://github.com/yuzu-emu/sirit.git
+ source = library-headers::git+https://github.com/citra-emu/ext-library-headers.git
source = git+https://github.com/google/googletest
source = git+https://github.com/arsenm/sanitizers-cmake
source = zycore::git+https://github.com/zyantific/zycore-c
@@ -92,6 +93,7 @@ pkgbase = citra-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = citra-git
depends = ffmpeg
diff --git a/PKGBUILD b/PKGBUILD
index b7882fe455d6..387f9e5bde35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r9594.54c499ed5
+pkgver=r9621.89663e0db
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -45,6 +45,7 @@ source=("$_pkgbase::git+https://github.com/citra-emu/citra.git"
"vulkan-headers::git+https://github.com/KhronosGroup/Vulkan-Headers.git"
"git+https://github.com/KhronosGroup/SPIRV-Headers.git"
"git+https://github.com/yuzu-emu/sirit.git"
+ "library-headers::git+https://github.com/citra-emu/ext-library-headers.git"
# cubeb's submodule
"git+https://github.com/google/googletest"
"git+https://github.com/arsenm/sanitizers-cmake"
@@ -82,6 +83,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -91,7 +93,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgbase"
- for submodule in {boost,nihstro,soundtouch,catch2,dynarmic,xbyak,fmt,enet,libressl,cubeb,discord-rpc,cpp-jwt,teakra,zstd,libyuv,cryptopp-cmake,cryptopp,dds-ktx,sdl2,lodepng,libusb,inih,openal-soft,glslang,vma,vulkan-headers,sirit};
+ for submodule in {boost,nihstro,soundtouch,catch2,dynarmic,xbyak,fmt,enet,libressl,cubeb,discord-rpc,cpp-jwt,teakra,zstd,libyuv,cryptopp-cmake,cryptopp,dds-ktx,sdl2,lodepng,libusb,inih,openal-soft,glslang,vma,vulkan-headers,sirit,library-headers};
do
git config --file=.gitmodules submodule.${submodule}.url "$srcdir/${submodule}"
done