summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92b08e48280e..831658d95857 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ckb-next
pkgdesc = Corsair Keyboard and Mouse Input Driver, release version
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.4.1
+ pkgrel = 1
url = https://github.com/ckb-next/ckb-next
install = ckb-next.install
arch = i686
@@ -13,12 +13,13 @@ pkgbase = ckb-next
depends = hicolor-icon-theme
depends = quazip
optdepends = libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)
+ optdepends = libpulse
provides = ckb-next
conflicts = ckb-git
conflicts = ckb-git-latest
conflicts = ckb-next
- source = https://github.com/ckb-next/ckb-next/archive/v0.4.0.tar.gz
- md5sums = 94eb8b6e23909629722d005ce0481b24
+ source = https://github.com/ckb-next/ckb-next/archive/v0.4.1.tar.gz
+ sha256sums = 373e7cc5bb2b894f4ef7e1c9d76f463842d4f389dfe4717e9beb39662a185351
pkgname = ckb-next
diff --git a/PKGBUILD b/PKGBUILD
index f5e6e7417380..66970c9921ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,32 @@
# Maintainer: Tasos Sahanidis <aur@tasossah.com>
# Contributor: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.4.1
+pkgrel=1
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
arch=('i686' 'x86_64')
url="https://github.com/ckb-next/ckb-next"
license=('GPL2')
depends=('qt5-base' 'hicolor-icon-theme' 'quazip')
makedepends=('git' 'cmake')
-optdepends=('libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)')
+optdepends=('libappindicator-gtk2: Ayatana indicators in Unity, KDE or Systray (GTK+ 2 library)' 'libpulse')
conflicts=('ckb-git' 'ckb-git-latest' 'ckb-next')
provides=('ckb-next')
install=ckb-next.install
source=("https://github.com/ckb-next/$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('94eb8b6e23909629722d005ce0481b24')
+sha256sums=('373e7cc5bb2b894f4ef7e1c9d76f463842d4f389dfe4717e9beb39662a185351')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
cmake -H. -Bbuild \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_BUILD_TYPE="Release" \
- -DCMAKE_INSTALL_LIBDIR="lib" \
- -DCMAKE_INSTALL_LIBEXECDIR="lib" \
- -DDISABLE_UPDATER=1
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DCMAKE_INSTALL_LIBEXECDIR="lib" \
+ -DDISABLE_UPDATER=1 \
+ -DUDEV_RULE_DIRECTORY="/usr/lib/udev/rules.d" \
+ -DFORCE_INIT_SYSTEM="systemd"
cmake --build build --target all
}