summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xckb-next.install66
3 files changed, 4 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c5676fac27b..76b028a7fe1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ckb-next
pkgdesc = Corsair Keyboard and Mouse Input Driver, release version
pkgver = 0.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ckb-next/ckb-next
install = ckb-next.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 4206452d6afc..6779b1adc5cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Light2Yellow <oleksii.vilchanskyi@gmail.com>
pkgname=ckb-next
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Corsair Keyboard and Mouse Input Driver, release version"
arch=('i686' 'x86_64' 'pentium4')
url="https://github.com/ckb-next/ckb-next"
diff --git a/ckb-next.install b/ckb-next.install
index 81aadc2c124f..889fc8a7a995 100755
--- a/ckb-next.install
+++ b/ckb-next.install
@@ -13,72 +13,10 @@ blue="${bold}$(tput setaf 4)"
yellow="${bold}$(tput setaf 3)"
_as_service() {
- cat << EOF
-
-You might want to run ckb-next-daemon as a systemd service:
-
- systemctl enable ckb-next-daemon.service
- systemctl start ckb-next-daemon.service
-
-EOF
+ note "You need to run ckb-next-daemon as a systemd service:
+ systemctl enable --now ckb-next-daemon.service"
}
-_disable_daemon() {
- running="$(systemctl is-enabled ckb-next-daemon.service)"
- if [[ "$running" = "enabled" ]]; then
- systemctl disable ckb-next-daemon.service
- fi
-}
-
-_terminate_gui_daemon() {
- msg_blue "Terminating ckb-next GUI"
-
- killall -TERM ckb 2>/dev/null
- killall -TERM ckb-next 2>/dev/null
-
-
- msg_blue "Terminating ckb-next daemon"
-
- running="$(systemctl is-active ckb-daemon.service)"
- if [[ "$running" = "active" ]]; then
- systemctl stop ckb-daemon.service
- fi
-
- running="$(systemctl is-active ckb-next-daemon.service)"
- if [[ "$running" = "active" ]]; then
- systemctl stop ckb-next-daemon.service
- fi
-
- running="$(systemctl is-enabled ckb-daemon.service 2>/dev/null)"
- if [[ "$running" = "enabled" ]]; then
- systemctl disable ckb-daemon.service
- fi
-}
-
-# arg 1: the new package version
post_install() {
_as_service
}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- _terminate_gui_daemon
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- systemctl daemon-reload
-}
-
-# arg 1: the old package version
-pre_remove() {
- _terminate_gui_daemon
- _disable_daemon
-}
-
-# arg 1: the old package version
-post_remove() {
- systemctl daemon-reload
-}