summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD52
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09b3087af2fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cl-usocket
+ pkgdesc = Universal socket library for Common Lisp
+ pkgver = 0.8.4
+ pkgrel = 1
+ url = https://usocket.common-lisp.dev/
+ arch = any
+ license = MIT
+ checkdepends = cl-rt
+ makedepends = git
+ depends = common-lisp
+ depends = cl-asdf
+ depends = cl-split-sequence
+ depends = cl-bordeaux-threads
+ source = cl-usocket::git+https://github.com/usocket/usocket#commit=57d7d00ed42d45803c0b3e4041413477fcec441a
+ b2sums = SKIP
+
+pkgname = cl-usocket
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c07f429038cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=cl-usocket
+_pkgname="${pkgname#cl-}"
+pkgver=0.8.4
+pkgrel=1
+pkgdesc='Universal socket library for Common Lisp'
+arch=('any')
+url='https://usocket.common-lisp.dev/'
+license=('MIT')
+depends=(
+ 'common-lisp'
+ 'cl-asdf'
+ 'cl-split-sequence'
+ 'cl-bordeaux-threads'
+)
+makedepends=('git')
+checkdepends=('cl-rt')
+_commit='57d7d00ed42d45803c0b3e4041413477fcec441a'
+source=("$pkgname::git+https://github.com/usocket/usocket#commit=$_commit")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
+}
+
+package() {
+ cd "$pkgname"
+
+ # create directories
+ install -vd \
+ "$pkgdir/usr/share/common-lisp/source/$_pkgname" \
+ "$pkgdir/usr/share/common-lisp/systems"
+
+ # library
+ cp -vr \
+ backend tests vendor \
+ ./*.{asd,lisp,sexp,system} \
+ "$pkgdir/usr/share/common-lisp/source/$_pkgname"
+
+ pushd "$pkgdir/usr/share/common-lisp/systems"
+ ln -s "../source/$_pkgname"/*.asd .
+ popd
+
+ # documentation
+ install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md notes/*
+
+ # license
+ install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}