summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--arch.patch26
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89cb2fa2eec7..95b49b7cda9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,7 @@ pkgbase = clash-premium-script
source = arch.patch
source = config.yaml
sha256sums = SKIP
- sha256sums = df6c6ee3217fc6e8a69aaf6b4e291eb963bdc4f512fa1d2d96b284554195a79f
+ sha256sums = caea15247d1b324cc3e4a1e0b1504788e2180218ef93f2c934616897b372906b
sha256sums = 1938bc7544f8e33a6e41636f45e87a17de2eac0ca14f47c2f7a71c3c87341bf0
pkgname = clash-premium-script
diff --git a/PKGBUILD b/PKGBUILD
index 702a289a7f75..092acdb49625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,9 @@ makedepends=('git')
backup=("etc/clash/config.yaml" "etc/default/clash")
source=("git+https://github.com/Kr328/clash-premium-installer.git"
"arch.patch"
- "config.yaml")
+ "config.yaml")
sha256sums=('SKIP'
- 'df6c6ee3217fc6e8a69aaf6b4e291eb963bdc4f512fa1d2d96b284554195a79f'
+ 'caea15247d1b324cc3e4a1e0b1504788e2180218ef93f2c934616897b372906b'
'1938bc7544f8e33a6e41636f45e87a17de2eac0ca14f47c2f7a71c3c87341bf0')
pkgver() {
diff --git a/arch.patch b/arch.patch
index 5cc7c28150a8..5b9746f0b398 100644
--- a/arch.patch
+++ b/arch.patch
@@ -52,15 +52,33 @@ index 18fa5fc..e333382 100644
[Install]
WantedBy=multi-user.target
diff --git a/scripts/setup-tun.sh b/scripts/setup-tun.sh
-index 2c1a601..f5d5d0f 100755
+index 2c1a601..5587a1e 100755
--- a/scripts/setup-tun.sh
+++ b/scripts/setup-tun.sh
-@@ -8,7 +8,7 @@ ip rule del fwmark "$NETFILTER_MARK" lookup "$IPROUTE2_TABLE_ID" > /dev/null 2>
+@@ -8,8 +8,6 @@ ip rule del fwmark "$NETFILTER_MARK" lookup "$IPROUTE2_TABLE_ID" > /dev/null 2>
ip rule add fwmark "$NETFILTER_MARK" lookup "$IPROUTE2_TABLE_ID"
nft -f - << EOF
-define LOCAL_SUBNET = {127.0.0.0/8, 224.0.0.0/4, 192.168.0.0/16, 10.0.0.0/8, 172.16.0.0/12}
-+define LOCAL_SUBNET = $LOCAL_SUBNET
-
+-
table clash
flush table clash
+
+@@ -20,7 +18,7 @@ table clash {
+ ip protocol != { tcp, udp } accept
+
+ meta cgroup $BYPASS_CGROUP_CLASSID accept
+- ip daddr \$LOCAL_SUBNET accept
++ ip daddr $LOCAL_SUBNET accept
+
+ ct state new ct mark set $NETFILTER_MARK
+ ct mark $NETFILTER_MARK mark set $NETFILTER_MARK
+@@ -32,7 +30,7 @@ table clash {
+ ip protocol != { tcp, udp } accept
+
+ iif utun accept
+- ip daddr \$LOCAL_SUBNET accept
++ ip daddr $LOCAL_SUBNET accept
+
+ mark set $NETFILTER_MARK
+ }