summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD68
2 files changed, 45 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 416ada781813..9719b6d0bdaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,29 @@
-# Generated by mksrcinfo v8
-# Sat May 20 19:21:43 UTC 2017
pkgbase = clementine-git
pkgdesc = A modern music player and library organizer
- pkgver = 1.3.1.r334.gf8f6feff3
- pkgrel = 1
+ pkgver = 1.4.0rc1.r901.g7b678f26e.14.gc93b4e114
+ pkgrel = 2
url = http://www.clementine-player.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = boost
makedepends = cmake
- makedepends = mesa
- makedepends = sparsehash
makedepends = git
+ makedepends = qt5-tools
+ makedepends = sparsehash
depends = chromaprint
- depends = crypto++
- depends = fftw
- depends = gcc-libs
- depends = glew
- depends = glib2
- depends = glibc
depends = gst-plugins-base-libs
- depends = gstreamer
depends = libcdio
- depends = libgl
depends = libgpod
- depends = liblastfm
+ depends = liblastfm-qt5
depends = libmtp
- depends = libpulse
- depends = libx11
+ depends = libmygpo-qt5
depends = protobuf
- depends = qjson
- depends = qt4
- depends = sqlite
- depends = taglib
- depends = zlib
+ depends = qt5-x11extras
+ depends = projectm
+ depends = alsa-lib
+ depends = libpulse
+ depends = crypto++
+ depends = hicolor-icon-theme
optdepends = gst-plugins-base: "Base" plugin libraries
optdepends = gst-plugins-good: "Good" plugin libraries
optdepends = gst-plugins-bad: "Bad" plugin libraries
@@ -47,4 +36,3 @@ pkgbase = clementine-git
sha256sums = SKIP
pkgname = clementine-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e4a8b11a1600..89fdce529d90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,7 @@
-# Maintainer: Eduardo Sánchez Muñoz
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: zan <zan@420blaze.it>
+# Contributor: Jacob Henner <code@ventricle.us>
+# Contributor: Eduardo Sánchez Muñoz
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: BlackEagle <ike.devolder@gmail.com>
@@ -7,50 +10,45 @@
# Based on community/clementine PKGBUILD
pkgname=clementine-git
-pkgver=1.3.1.r334.gf8f6feff3
-pkgrel=1
+pkgver=1.4.0rc1.r901.g7b678f26e.14.gc93b4e114
+pkgrel=2
pkgdesc='A modern music player and library organizer'
url='http://www.clementine-player.org/'
-license=('GPL')
-arch=('i686' 'x86_64')
-depends=('chromaprint' 'crypto++' 'fftw' 'gcc-libs' 'glew' 'glib2' 'glibc'
- 'gst-plugins-base-libs' 'gstreamer' 'libcdio' 'libgl' 'libgpod'
- 'liblastfm' 'libmtp' 'libpulse' 'libx11' 'protobuf' 'qjson' 'qt4'
- 'sqlite' 'taglib' 'zlib')
-makedepends=('boost' 'cmake' 'mesa' 'sparsehash' 'git')
-optdepends=('gst-plugins-base: "Base" plugin libraries'
- 'gst-plugins-good: "Good" plugin libraries'
- 'gst-plugins-bad: "Bad" plugin libraries'
- 'gst-plugins-ugly: "Ugly" plugin libraries'
- 'gst-libav: Libav plugin'
- 'gvfs: Various devices support')
-conflicts=('clementine')
-provides=('clementine')
+license=(GPL)
+arch=(x86_64)
+depends=(chromaprint gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5
+ protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
+makedepends=(boost cmake git qt5-tools sparsehash)
+optdepends=(
+ 'gst-plugins-base: "Base" plugin libraries'
+ 'gst-plugins-good: "Good" plugin libraries'
+ 'gst-plugins-bad: "Bad" plugin libraries'
+ 'gst-plugins-ugly: "Ugly" plugin libraries'
+ 'gst-libav: Libav plugin'
+ 'gvfs: Various devices support')
+conflicts=(clementine)
+provides=(clementine)
source=("git+https://github.com/clementine-player/Clementine.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/Clementine"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "$srcdir/Clementine"
+ cd Clementine
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ #git describe --long --tags --exclude 1.4.0rc1-* | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- mkdir -p "$srcdir/clementine-build"
- cd "$srcdir/clementine-build"
-
- cmake "$srcdir/Clementine" \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_WERROR=off \
- -DCMAKE_INSTALL_PREFIX="/usr"
- make
+ export LDFLAGS="-Wl,--copy-dt-needed-entries"
+ cmake -B build -S Clementine -Wno-dev \
+ -DCMAKE_CXX_FLAGS="-fpermissive" \
+ -DCMAKE_CXX_STANDARD=17 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_SYSTEM_PROJECTM=ON \
+ -DUSE_SYSTEM_TAGLIB=OFF
+
+ cmake --build build
}
package() {
- cd "$srcdir/clementine-build"
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}