summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d436c2df5d1..c6e7ba0120ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,13 +7,14 @@ pkgbase = clightd-git
arch = x86_64
license = GPL
makedepends = git
- depends = systemd
+ depends = systemd>=221
depends = linux-api-headers
depends = libx11
depends = libxrandr
depends = libxext
depends = polkit
depends = libxss
+ depends = ddcutil
optdepends = clight-git: user service to automagically change screen backlight matching ambient brightness.
source = git://github.com/FedeDP/Clightd.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 92bbceefccf8..d3ecfb0a4c85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc="Bus interface to change screen brightness and capture frames from webca
arch=('i686' 'x86_64')
url="https://github.com/FedeDP/${_gitname}"
license=('GPL')
-depends=('systemd' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit' 'libxss')
+depends=('systemd>=221' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit' 'libxss' 'ddcutil')
makedepends=('git')
optdepends=('clight-git: user service to automagically change screen backlight matching ambient brightness.')
source=("git://github.com/FedeDP/${_gitname}.git")
@@ -26,5 +26,5 @@ build() {
package() {
cd $srcdir/$_gitname
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install WITH_DDC=1
}