summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a129b3ff2f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = clogs
+ pkgdesc = C++ library for sorting and searching in OpenCL applications
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/clogs/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ source = http://skylink.dl.sourceforge.net/project/clogs/1.5.0/clogs-1.5.0.tar.bz2
+ sha256sums = SKIP
+
+pkgname = clogs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4d997c69e0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+
+pkgname=clogs
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="C++ library for sorting and searching in OpenCL applications"
+arch=(x86_64 i686)
+url="http://sourceforge.net/projects/clogs/"
+license=(MIT)
+
+source=("http://skylink.dl.sourceforge.net/project/clogs/1.5.0/clogs-1.5.0.tar.bz2")
+sha256sums=("SKIP")
+
+build() {
+ cd $pkgname-$pkgver
+ python2 waf configure --prefix=/usr
+ python2 waf build
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python2 waf install --destdir=$pkgdir
+}