summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbd747f19277
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 23:03:40 UTC 2016
+pkgbase = clpeak-git
+ pkgdesc = A tool which profiles OpenCL devices to find their peak capacities
+ pkgver = r112.4be2b6f
+ pkgrel = 1
+ url = https://github.com/krrishnarraj/clpeak
+ arch = i386
+ arch = x86_64
+ license = custom:unlicense
+ makedepends = git
+ makedepends = opencl-headers
+ depends = ocl-icd
+ conflicts = clpeak
+ source = git+https://github.com/krrishnarraj/clpeak.git
+ md5sums = SKIP
+
+pkgname = clpeak-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f6344b9cd34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Zanny <lordzanny@gmail.com>
+
+pkgname=clpeak-git
+pkgver=r112.4be2b6f
+pkgrel=1
+pkgdesc="A tool which profiles OpenCL devices to find their peak capacities"
+arch=(i386 x86_64)
+url="https://github.com/krrishnarraj/clpeak"
+license=(custom:unlicense)
+depends=(ocl-icd)
+conflicts=(clpeak)
+makedepends=(git opencl-headers)
+source=('git+https://github.com/krrishnarraj/clpeak.git')
+md5sums=('SKIP')
+
+_name=clpeak
+
+pkgver() {
+ cd "$srcdir/$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_name"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_name"
+ install -D -m755 clpeak "$pkgdir/usr/bin/$_name"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}