summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--ChangeLog31
-rw-r--r--PKGBUILD4
3 files changed, 36 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ca8f4cff3f5..b2f911fdb92c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clustershell
pkgdesc = Python framework for efficient cluster administration
- pkgver = 1.8.1
+ pkgver = 1.8.3
pkgrel = 2
url = http://cea-hpc.github.io/clustershell/
changelog = ChangeLog
@@ -11,8 +11,8 @@ pkgbase = clustershell
depends = python
optdepends = openssh: Secure SHell client to connect to distant machines,
optdepends = vim: Vi Improved
- source = https://github.com/cea-hpc/clustershell/archive/v1.8.1.tar.gz
- sha256sums = 0c3da87108de8b735f40b5905b8dcd8084a234849aee2a8b8d2e20b99b57100c
+ source = https://github.com/cea-hpc/clustershell/archive/v1.8.3.tar.gz
+ sha256sums = 86b0d524e5e50c0a15faec01d8642f0ff12ba78d50b7e7b660261be5d53fed9c
pkgname = clustershell
diff --git a/ChangeLog b/ChangeLog
index 496c0436d9c7..aa57f3c5ba3e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,34 @@
+2019-12-01 S. Thiell <sthiell@stanford.edu>
+
+ * Version 1.8.3 released. The main changes are listed below.
+
+ * NodeUtils: use yaml.safe_load() instead of default loader (#417)
+
+ * Tree-mode doesn't work with multi-hop gateways (#419)
+
+ * Silent error on Python version mismatch with gateway (#388)
+
+ * clush: support --worker/-R when topology.conf is present (#386)
+
+2019-08-12 S. Thiell <sthiell@stanford.edu>
+
+ * Version 1.8.2 released. The main changes are listed below.
+
+ * CLI/Display: use utf-8 (or non-ascii) encoding (#400)
+
+ * Defaults: add NodeSet's default folding axis (#401)
+
+ * EngineTimer: fix misuse of epsilon when firing timer (#399)
+
+ * xCAT group bindings: performance update (#398)
+
+ * Slurm group bindings: fix issue where job ids were used instead of user
+ names (#405)
+
+ * Doc: disable smartquotes (#402) and fix typo, %r is not for rank (#409)
+
+ * Packaging: add support for RHEL8 (#413)
+
2018-10-30 S. Thiell <sthiell@stanford.edu>
* Version 1.8.1 released. The main changes are listed below.
diff --git a/PKGBUILD b/PKGBUILD
index 90f81903d5d2..54e4b9115d00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aurelien Cedeyn <aurelien.cedeyn@gmail.com>
# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
pkgname="clustershell"
-pkgver=1.8.1
+pkgver=1.8.3
pkgrel=2
pkgdesc="Python framework for efficient cluster administration"
arch=(any)
@@ -20,7 +20,7 @@ install=
changelog=ChangeLog
source=(https://github.com/cea-hpc/${pkgname}/archive/v${pkgver}.tar.gz)
noextract=()
-sha256sums=('0c3da87108de8b735f40b5905b8dcd8084a234849aee2a8b8d2e20b99b57100c')
+sha256sums=('86b0d524e5e50c0a15faec01d8642f0ff12ba78d50b7e7b660261be5d53fed9c')
build() {
echo "Directory: ${srcdir}/${pkgname}-${pkgver}"