summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
-rw-r--r--python3.12-compatibility.patch49
4 files changed, 8 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 044e7dc8a9c9..9f3e3f626b2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cmake-lint
pkgdesc = Check for coding style issues in CMake files
- pkgver = 1.4.2
- pkgrel = 7
+ pkgver = 1.4.3
+ pkgrel = 1
url = https://github.com/cmake-lint/cmake-lint
arch = any
license = Apache-2.0
@@ -11,9 +11,7 @@ pkgbase = cmake-lint
makedepends = python-setuptools
makedepends = python-wheel
depends = python
- source = cmake-lint-1.4.2.tar.gz::https://github.com/cmake-lint/cmake-lint/archive/1.4.2.tar.gz
- source = python3.12-compatibility.patch
- sha256sums = bf060987c74e07890f7314a4832c2e54ffb9c5c1e6d799387bc438010f918676
- sha256sums = 4f1573fa02d542067f0d20eb178f50354bed451173c4f73175098ca4c6e569c1
+ source = cmake-lint-1.4.3.tar.gz::https://github.com/cmake-lint/cmake-lint/archive/1.4.3.tar.gz
+ sha256sums = 7a2be3b179c565373cb7ccfe3076b0d1fa051f2234b52e29f69fa386042ebb74
pkgname = cmake-lint
diff --git a/.gitignore b/.gitignore
index f121dd0b3998..0df2b70016b9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,3 @@
!.nvchecker.toml
!.SRCINFO
!PKGBUILD
-!python3.12-compatibility.patch
diff --git a/PKGBUILD b/PKGBUILD
index 7567d19b7243..03a759415456 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Richard Quirk
pkgname=cmake-lint
-pkgver=1.4.2
-pkgrel=7
+pkgver=1.4.3
+pkgrel=1
pkgdesc="Check for coding style issues in CMake files"
arch=(any)
url="https://github.com/cmake-lint/cmake-lint"
@@ -16,23 +16,11 @@ makedepends=(
python-wheel
)
checkdepends=(python-pytest)
-source=(
- "$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
- "python3.12-compatibility.patch"
-)
-sha256sums=(
- 'bf060987c74e07890f7314a4832c2e54ffb9c5c1e6d799387bc438010f918676'
- '4f1573fa02d542067f0d20eb178f50354bed451173c4f73175098ca4c6e569c1'
-)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('7a2be3b179c565373cb7ccfe3076b0d1fa051f2234b52e29f69fa386042ebb74')
_archive="$pkgname-$pkgver"
-prepare() {
- cd "$_archive"
-
- patch --forward --strip=1 --input="$srcdir/python3.12-compatibility.patch"
-}
-
build() {
cd "$_archive"
diff --git a/python3.12-compatibility.patch b/python3.12-compatibility.patch
deleted file mode 100644
index 5e67b1bee5ba..000000000000
--- a/python3.12-compatibility.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --unified --recursive --text --new-file cmake-lint-1.4.2.orig/setup.py cmake-lint-1.4.2/setup.py
---- cmake-lint-1.4.2.orig/setup.py 2024-04-22 15:48:16.433625415 +0200
-+++ cmake-lint-1.4.2/setup.py 2024-04-22 15:59:27.546256097 +0200
-@@ -1,22 +1,13 @@
- #! /usr/bin/env python
-
--import imp
-+from importlib.machinery import SourceFileLoader
-
- from setuptools import setup
-
-
- def get_version():
-- ver_file = None
-- try:
-- ver_file, pathname, description = imp.find_module(
-- '__version__', ['cmakelint'])
-- vermod = imp.load_module(
-- '__version__', ver_file, pathname, description)
-- version = vermod.VERSION
-- return version
-- finally:
-- if ver_file is not None:
-- ver_file.close()
-+ version_module = SourceFileLoader('__version__', 'cmakelint/__version__.py').load_module()
-+ return version_module.VERSION
-
-
- def read_without_comments(filename):
-@@ -30,7 +21,6 @@
- setup(name='cmakelint',
- version=get_version(),
- packages=['cmakelint'],
-- scripts=['bin/cmakelint'],
- entry_points={
- 'console_scripts': [
- 'cmakelint = cmakelint.main:main'
-diff --unified --recursive --text --new-file cmake-lint-1.4.2.orig/test/cmakelint_test.py cmake-lint-1.4.2/test/cmakelint_test.py
---- cmake-lint-1.4.2.orig/test/cmakelint_test.py 2024-04-22 15:48:16.433625415 +0200
-+++ cmake-lint-1.4.2/test/cmakelint_test.py 2024-04-22 15:59:27.539589434 +0200
-@@ -19,7 +19,7 @@
-
- import cmakelint.__version__
- import cmakelint.main
--import mock
-+from unittest import mock
-
-
- # stderr suppression from https://stackoverflow.com/a/1810086