summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
-rw-r--r--cmake.install12
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79bb718a2827
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 4.2.0
+# Mon Jan 12 17:41:10 UTC 2015
+pkgbase = cmake30
+ pkgdesc = A cross-platform open-source make system
+ pkgver = 3.0.2
+ pkgrel = 2
+ url = http://www.cmake.org/
+ install = cmake.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = curl
+ depends = libarchive
+ depends = shared-mime-info
+ source = http://www.cmake.org/files/v3.0/cmake-3.0.2.tar.gz
+ sha512sums = de267bd6c5b318e48fae64c28947de009fb2413bdc6b4454b5e4bbb7d50b78aaef5d7e9d9655cfb9299aa5704fd3e4bbabc6816d3f378f76856f56ab161efe02
+
+pkgname = cmake30
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe740244c439
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+# Original Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+# This package does not include editor syntax files or the Qt CMake GUI.
+
+pkgname=cmake30
+pkgver=3.0.2
+pkgrel=2
+pkgdesc='A cross-platform open-source make system'
+arch=(i686 x86_64)
+url="http://www.cmake.org/"
+license=(custom)
+depends=(curl libarchive shared-mime-info)
+install=cmake.install
+source=("http://www.cmake.org/files/v${pkgver%.*}/cmake-${pkgver}.tar.gz")
+sha512sums=('de267bd6c5b318e48fae64c28947de009fb2413bdc6b4454b5e4bbb7d50b78aaef5d7e9d9655cfb9299aa5704fd3e4bbabc6816d3f378f76856f56ab161efe02')
+
+build() {
+ cd cmake-${pkgver}
+
+ if in_array ccache "${BUILDENV[@]}"; then
+ local ccache_arg='--enable-ccache'
+ else
+ local ccache_arg=''
+ fi
+
+ ./bootstrap \
+ --prefix=/usr \
+ --mandir=/share/man \
+ --system-libs \
+ --parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN) \
+ ${ccache_arg}
+ make
+}
+
+package() {
+ cd cmake-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 Copyright.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+
+ mv "${pkgdir}"/usr/bin/ccmake{,-3.0}
+ mv "${pkgdir}"/usr/bin/cmake{,-3.0}
+ mv "${pkgdir}"/usr/bin/cpack{,-3.0}
+ mv "${pkgdir}"/usr/bin/ctest{,-3.0}
+
+ rm -r "${pkgdir}"/usr/share/aclocal/
+}
diff --git a/cmake.install b/cmake.install
new file mode 100644
index 000000000000..55f6c843bd10
--- /dev/null
+++ b/cmake.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-mime-database usr/share/mime &> /dev/null
+ [[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}