summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 614a0d3dba7d..c33ab3938ae5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = cmus-git
pkgdesc = Small, fast and powerful console music player for Unix-like operating systems.
- pkgver = v2.8.0.r24.gd1290d5
- pkgrel = 4
+ pkgver = v2.8.0.r45.g33fad6e
+ pkgrel = 1
url = https://cmus.github.io/
arch = x86_64
+ arch = aarch64
license = GPL
makedepends = git
makedepends = faad2
@@ -42,7 +43,7 @@ pkgbase = cmus-git
optdepends = wavpack: for wavpack input plugin support
provides = cmus
conflicts = cmus
- source = git://github.com/cmus/cmus
+ source = git://github.com/KamranMackey/cmus
sha512sums = SKIP
pkgname = cmus-git
diff --git a/PKGBUILD b/PKGBUILD
index fb80b31571e6..69b1f60795be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Kamran Mackey <kamranm1200@gmail.com>
pkgname=cmus-git
-pkgver=v2.8.0.r24.gd1290d5
-pkgrel=4
+pkgver=v2.8.0.r45.g33fad6e
+pkgrel=1
pkgdesc="Small, fast and powerful console music player for Unix-like operating systems."
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://cmus.github.io/"
depends=('ncurses' 'libdiscid')
makedepends=('git'
@@ -43,7 +43,7 @@ optdepends=('alsa-lib: for ALSA output plugin support'
conflicts=('cmus')
provides=('cmus')
license=('GPL')
-source=(git://github.com/cmus/cmus)
+source=(git://github.com/KamranMackey/cmus)
sha512sums=('SKIP')
_gitname=cmus
@@ -53,14 +53,16 @@ pkgver() {
}
build() {
- cd "$_gitname"
+ cd "$_gitname"/src/
+ chmod +x configure
./configure prefix=/usr
make
}
package() {
- cd "$_gitname"
+ cd "$_gitname"/src/
make DESTDIR="$pkgdir" install
+ cd ../
install -Dm644 contrib/cmus.bash-completion "$pkgdir"/usr/share/bash-completion/completions/cmus
install -Dm644 contrib/_cmus "$pkgdir"/usr/share/zsh/site-functions/_cmus
}