summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bfc6f6fde8b..e0388bffedef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = cockatrice-server
- pkgdesc = Open-source multiplatform supported program for playing tabletop card games over a network.
+ pkgdesc = Open-source multiplatform supported program for playing tabletop card games over a network - server package
pkgver = 2.6.1
pkgrel = 2
url = https://cockatrice.github.io/
@@ -10,8 +10,6 @@ pkgbase = cockatrice-server
depends = protobuf
depends = qt5-websockets
optdepends = mariadb: database support
- provides = cockatrice-server
- conflicts = cockatrice-server
source = https://github.com/Cockatrice/Cockatrice/archive/2018-07-17-Release-2.6.1.tar.gz
sha256sums = 3fbd3d51073f983602a78150e5e05b80e410a840a21e40c394f36d4b6f72b123
diff --git a/PKGBUILD b/PKGBUILD
index a777d0cdd8d0..a5a0527794dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,29 +7,26 @@ pkgname=cockatrice-server
pkgver=2.6.1
_reldate=2018-07-17
pkgrel=2
-pkgdesc='Open-source multiplatform supported program for playing tabletop card games over a network.'
+pkgdesc='Open-source multiplatform supported program for playing tabletop card games over a network - server package'
arch=('i686' 'x86_64')
url='https://cockatrice.github.io/'
license=('GPL2')
depends=('protobuf' 'qt5-websockets')
optdepends=('mariadb: database support')
makedepends=('cmake')
-provides=('cockatrice-server')
-conflicts=('cockatrice-server')
-_relname="$_reldate-Release-$pkgver"
-source=("https://github.com/Cockatrice/Cockatrice/archive/$_relname.tar.gz")
+_relname="${_reldate}-Release-${pkgver}"
+source=("https://github.com/Cockatrice/Cockatrice/archive/${_relname}.tar.gz")
sha256sums=('3fbd3d51073f983602a78150e5e05b80e410a840a21e40c394f36d4b6f72b123')
build() {
- cd "$srcdir/Cockatrice-$_relname"
- test -d build && rm -rf build
- mkdir build
+ cd "${srcdir}/Cockatrice-${_relname}"
+ mkdir -p build
cd build
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DWITH_ORACLE=0 -DWITH_CLIENT=0 -DWITH_SERVER=1 ..
make
}
package() {
- cd "$srcdir/Cockatrice-$_relname/build"
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/Cockatrice-${_relname}/build"
+ make DESTDIR="${pkgdir}/" install
}