summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD37
-rw-r--r--dzh365.install10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d8336a53086
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = com.dzh365.deepin
+ pkgdesc = dzh365 Client on Deepin Wine5
+ pkgver = 8.31.00.18788.47
+ pkgrel = 0
+ url = http://www.gw.com.cn/
+ install = dzh365.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine5-stable>=5.0.0.15
+ depends = deepin-wine-helper
+ depends = p7zip
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.dzh365.deepin/com.dzh365.deepin_8.31.00.18788.47deepin0_i386.deb
+ sha512sums = 2a1ceb07a2db90d679646d54399852b524769d497dd53558d4bc5c5dae04ce4e399c400eaa26363fdb449859cc831b00bf4c180c11ede39a0f7a499427142658
+
+pkgname = com.dzh365.deepin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c64b6b0d8edd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributer: Sam L. Yes <samlukeyes123@gmail.com>
+pkgname=com.dzh365.deepin
+pkgver=8.31.00.18788.47
+pkgrel=0
+epoch=
+pkgdesc="dzh365 Client on Deepin Wine5"
+arch=('i686' 'x86_64')
+url="http://www.gw.com.cn/"
+license=('unknown')
+groups=()
+depends=('deepin-wine5-stable>=5.0.0.15' 'deepin-wine-helper' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+replaces=()
+backup=()
+options=()
+install=dzh365.install
+changelog=
+source=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/${pkgname}/${pkgname}_${pkgver}deepin${pkgrel}_i386.deb")
+sha512sums=('2a1ceb07a2db90d679646d54399852b524769d497dd53558d4bc5c5dae04ce4e399c400eaa26363fdb449859cc831b00bf4c180c11ede39a0f7a499427142658')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries
+ cd opt/apps/${pkgname}/files
+ sed -i "/extract_archive \"/d" run.sh
+ sed -i "s|\$HOME/.deepinwine/deepin-wine-helper|/opt/deepinwine/tools|" run.sh
+ sed -i "s|\$HOME/.deepinwine|/usr/lib|" run.sh
+ rm wine_archive.* helper_archive.*
+}
diff --git a/dzh365.install b/dzh365.install
new file mode 100644
index 000000000000..b6145177bea9
--- /dev/null
+++ b/dzh365.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ echo
+ echo "Remove ~/.deepinwine/Deepin-dzh365 to generate a new bottle."
+ echo
+}
+
+post_remove() {
+ echo "Deleting existing dzh365 bottles..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-dzh365/ \;
+} \ No newline at end of file