summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD37
-rw-r--r--foxmail.install10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..064d9821f827
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = com.foxmail.deepin
+ pkgdesc = Tencent Foxmail Client on Deepin Wine5
+ pkgver = 7.2
+ pkgrel = 5
+ url = https://www.foxmail.com/
+ install = foxmail.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine5-stable>=5.0.0.7
+ depends = deepin-wine-helper>=5.1.8
+ depends = p7zip
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.foxmail.deepin/com.foxmail.deepin_7.2deepin5_i386.deb
+ sha512sums = a663bb259583d7e1006a948c50fbc768a226568f0f74c3ae13a4afdae76f93fb4aedf6c423c4acb7021ae010c5e8d2dd0e14fe3e4c017ff6abb38e30bdc4d8f5
+
+pkgname = com.foxmail.deepin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..a40f9b983ccc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributer: Sam L. Yes <samlukeyes123@gmail.com>
+pkgname=com.foxmail.deepin
+pkgver=7.2
+pkgrel=5
+epoch=
+pkgdesc="Tencent Foxmail Client on Deepin Wine5"
+arch=('i686' 'x86_64')
+url="https://www.foxmail.com/"
+license=('unknown')
+groups=()
+depends=('deepin-wine5-stable>=5.0.0.7' 'deepin-wine-helper>=5.1.8' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+replaces=()
+backup=()
+options=()
+install=foxmail.install
+changelog=
+source=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/${pkgname}/${pkgname}_${pkgver}deepin${pkgrel}_i386.deb")
+sha512sums=('a663bb259583d7e1006a948c50fbc768a226568f0f74c3ae13a4afdae76f93fb4aedf6c423c4acb7021ae010c5e8d2dd0e14fe3e4c017ff6abb38e30bdc4d8f5')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries
+ cd opt/apps/${pkgname}/files
+ sed -i "/extract_archive \"/d" run.sh
+ sed -i "s|\$HOME/.deepinwine/deepin-wine-helper|/opt/deepinwine/tools|" run.sh
+ sed -i "s|\$HOME/.deepinwine|/usr/lib|" run.sh
+ rm wine_archive.* helper_archive.*
+}
diff --git a/foxmail.install b/foxmail.install
new file mode 100644
index 000000000000..1d7451a929a2
--- /dev/null
+++ b/foxmail.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ echo
+ echo "Remove ~/.deepinwine/Deepin-Foxmail to generate a new bottle."
+ echo
+}
+
+post_remove() {
+ echo "Deleting existing Foxmail bottles..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-Foxmail/ \;
+} \ No newline at end of file