summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
3 files changed, 47 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c4e84355096d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = concalc
+ pkgdesc = Concalc is a calculator for the Linux console
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = http://extcalc-linux.sourceforge.net/concalcdescr.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://downloads.sourceforge.net/extcalc-linux/concalc-0.9.3.tar.gz
+
+pkgname = concalc
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20fc8f41d16c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = concalc
+ pkgdesc = Concalc is a calculator for the Linux console
+ pkgver = 0.9.3
+ pkgrel = 1
+ url = http://extcalc-linux.sourceforge.net/concalcdescr.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://downloads.sourceforge.net/extcalc-linux/concalc-0.9.3.tar.gz
+ md5sums = 802f7753ef3f0141c5607b52d7ceb4bd
+
+pkgname = concalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d8882b32f0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+
+pkgname=concalc
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Concalc is a calculator for the Linux console"
+arch=('i686' 'x86_64')
+url="http://extcalc-linux.sourceforge.net/concalcdescr.html"
+license=('GPL')
+source=(http://downloads.sourceforge.net/extcalc-linux/$pkgname-$pkgver.tar.gz)
+md5sums=('802f7753ef3f0141c5607b52d7ceb4bd')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/src"
+ g++ -Os -s concalc.cpp global.cpp -o concalc
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 src/concalc $pkgdir/usr/bin/concalc
+ install -Dm644 man/concalc.1.gz $pkgdir/usr/share/man/man1/concalc.1.gz
+}