summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--.pre-commit-config.yaml14
-rw-r--r--PKGBUILD17
4 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..622d3e032afc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = configcat-cli-bin
+ pkgdesc = Configcat cli binary distribution
+ pkgver = 1.8.0
+ pkgrel = 1
+ url = https://github.com/configcat/cli
+ arch = x86_64
+ license = MIT
+ provides = configcat-cli
+ options = !strip
+ source = https://github.com/configcat/cli/releases/download/v1.8.0/configcat-cli_1.8.0_linux-x64.tar.gz
+ sha256sums = c9201ce80d589324fc2cf863f2352de377651d039b6aa5e0c79909eeb9f05731
+
+pkgname = configcat-cli-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d60fda9ca35
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+/pkg/
+/src/
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..883ec8dc0b15
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,14 @@
+repos:
+- repo: local
+ hooks:
+ - id: updpkgsums
+ name: updpkgsums
+ entry: updpkgsums
+ language: system
+ files: PKGBUILD
+ - id: makepkg
+ name: makepkg
+ entry: makepkg --printsrcinfo > .SRCINFO
+ language: system
+ files: PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa7654356412
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=configcat-cli-bin
+pkgver=1.8.0
+pkgrel=1
+pkgdesc="Configcat cli binary distribution"
+arch=('x86_64')
+url="https://github.com/configcat/cli"
+license=('MIT')
+provides=('configcat-cli')
+source=("https://github.com/configcat/cli/releases/download/v${pkgver//_/-}/configcat-cli_${pkgver//_/-}_linux-x64.tar.gz"
+ )
+sha256sums=('c9201ce80d589324fc2cf863f2352de377651d039b6aa5e0c79909eeb9f05731')
+options=("!strip")
+
+package() {
+ install -d "$pkgdir/usr/bin/"
+ install -D configcat "$pkgdir/usr/bin/"
+}