summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--conkyforecast.changelog26
-rw-r--r--conkyforecast.install24
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aeab8ac6e9f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = conkyforecast
+ pkgdesc = Provides weather forecast information to be displayed in conky.
+ pkgver = 2.24
+ pkgrel = 1
+ url = https://code.launchpad.net/~conky-companions/+junk/conkyforecast
+ install = conkyforecast.install
+ changelog = conkyforecast.changelog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python2
+ conflicts = conkyforecast-bzr
+ replaces = conkyforecast-bzr
+ source = https://launchpad.net/~conky-companions/+archive/ppa/+files/conkyforecast_2.24.tar.gz
+ sha256sums = 251dba60bc209a2f4181de856abb1fe553e8b983d1af40998235061e8679a54d
+
+pkgname = conkyforecast
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b63bf0e7b62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jeremy Pope <jpope at jpope dot org> PGP-Key: E00B4261
+# Contributor: Ryan Coyner <rcoyner@gmail.com>
+pkgname=conkyforecast
+pkgver=2.24
+pkgrel=1
+pkgdesc="Provides weather forecast information to be displayed in conky."
+arch=('i686' 'x86_64')
+url="https://code.launchpad.net/~conky-companions/+junk/conkyforecast"
+license=('GPL3')
+depends=('python2')
+conflicts=('conkyforecast-bzr')
+replaces=('conkyforecast-bzr')
+install=${pkgname}.install
+changelog=${pkgname}.changelog
+source=(https://launchpad.net/~conky-companions/+archive/ppa/+files/${pkgname}_${pkgver}.tar.gz)
+
+build() {
+
+ cd ${srcdir}/src
+ python2 setup.py build
+
+}
+
+package() {
+
+ cd ${srcdir}/src
+ python2 setup.py install --root=${pkgdir}
+ install -D -m644 README ${pkgdir}/usr/share/conkyforecast/README
+ # Make sure we call python2 to run conkyforecast
+ sed -i 's|/usr/bin/python|/usr/bin/python2|' ${pkgdir}/usr/share/conkyforecast/conkyForecast.py
+ sed -i 's|/usr/bin/python|/usr/bin/python2|' ${pkgdir}/usr/bin/conkyForecast
+
+}
+
+sha256sums=('251dba60bc209a2f4181de856abb1fe553e8b983d1af40998235061e8679a54d')
diff --git a/conkyforecast.changelog b/conkyforecast.changelog
new file mode 100644
index 000000000000..9c1371d1b23f
--- /dev/null
+++ b/conkyforecast.changelog
@@ -0,0 +1,26 @@
+2012-08-24
+* Switched to conkyforecast Weather Underground codebase
+
+2011-06-04
+* Updated to 2.20
+
+2010-12-25
+* Updated to 2.15
+
+2010-10-08
+* Hardcoded python2 paths into scripts since python (3.x) and python2
+ (legacy) will probably coexist for a while
+
+2010-08-29
+* Updated to 2.12
+
+2010-07-03
+* Renamed AUR package from conky-forecast to conkyforecast (the
+ official name of the project)
+* Updated WI, MI and BI datatype functionality to be in line with
+ gtk-desktop-info. Now Bearing icons with wind strength will be
+ displayed and calm wind will be output properly.
+* Replaced animated gif based images for variable wind with png images
+ as conky doesn't support gif animations yet - Thanks Bruce M
+* Added remaining bearing icons needed for alternative strength winds
+ (yellow, orange and red)
diff --git a/conkyforecast.install b/conkyforecast.install
new file mode 100644
index 000000000000..084395bd9c8c
--- /dev/null
+++ b/conkyforecast.install
@@ -0,0 +1,24 @@
+post_install() {
+/bin/cat << ENDOFMESSAGE
+>>
+>> Please read the README in /usr/share/conkyforecast/
+>> for pointers concerning configuration.
+>>
+>> As of 2.21, Conkyforecast provides support for
+>> Weather Underground as well. Since Weather.com
+>> have removed developer support [sic], you will
+>> only be able to continue using their services
+>> if you have your own login credentials. If that
+>> is not the case, using the Weather Underground
+>> script is recommended.
+
+ENDOFMESSAGE
+}
+
+post_upgrade() {
+post_install
+}
+
+op=$1
+shift
+$op $*