summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
-rw-r--r--context.install6
4 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8ab4911cad1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = context-bin
+ pkgdesc = ConTeXt LMTX, the Lean and Mean TeX eXperience with Lua, MetaPost, TeX, and XML
+ pkgver = 1.04
+ pkgrel = 1
+ url = https://wiki.contextgarden.net/Installation
+ install = context.install
+ arch = x86_64
+ license = GPL
+ provides = context
+ conflicts = texlive-core
+ source = http://lmtx.pragma-ade.nl/install-lmtx/context-linux-64.zip
+ md5sums = SKIP
+
+pkgname = context-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b2260cf3822
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: xerus <27jf at pm dot me>
+
+_pkgname=context
+pkgname=${_pkgname}-bin
+pkgver=1.04
+pkgrel=1
+pkgdesc='ConTeXt LMTX, the Lean and Mean TeX eXperience with Lua, MetaPost, TeX, and XML'
+arch=('x86_64')
+url="https://wiki.contextgarden.net/Installation"
+license=(GPL)
+depends=()
+provides=("${_pkgname}")
+conflicts=("texlive-core")
+optdepends=()
+source=("http://lmtx.pragma-ade.nl/install-lmtx/context-linux-64.zip")
+md5sums=(SKIP)
+install=${_pkgname}.install
+
+prepare() {
+ cd "${srcdir}"
+ chmod +x install.sh
+ ./install.sh
+}
+
+package() {
+ context="${pkgdir}/usr/share/context"
+ cd "tex"
+
+ install -d "$context"
+ cp -r texmf texmf-context "$context"
+ install -Dt "${pkgdir}/usr/bin" texmf-linux-64/bin/*
+}
+
+pkgver() {
+ cat "${srcdir}/tex/texmf-context/scripts/context/lua/mtx-context.xml" |
+ grep 'entry name="version"' | sed 's/.*>\(.*\)<.*/\1/'
+}
diff --git a/context.install b/context.install
new file mode 100644
index 000000000000..f5d5f0d72443
--- /dev/null
+++ b/context.install
@@ -0,0 +1,6 @@
+post_install() {
+ _contextshare=/usr/share/context
+ echo "Add the following to your shell rc file:
+ export TEXMF=${_contextshare}"
+ export TEXMF=${_contextshare}
+}