summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD40
2 files changed, 26 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 405ea8a31eb0..b7cb4f0c414d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Oct 13 00:30:36 UTC 2019
pkgbase = copyq-plugin-itemweb-git
pkgdesc = Clipboard manager with searchable and editable history. Itemweb plugin.
- pkgver = 20151130
+ pkgver = r4773.2217511c
pkgrel = 1
+ epoch = 1
url = https://github.com/hluk/CopyQ
arch = i686
arch = x86_64
license = GPL3
- makedepends = cmake
makedepends = git
+ makedepends = cmake
makedepends = qt5-tools
- makedepends = qt5-svg
- depends = qt5-webkit
depends = copyq-git
+ depends = qt5-webkit
+ depends = qt5-svg
provides = copyq-plugin-itemweb
conflicts = copyq-plugin-itemweb
source = copyq-plugin-itemweb-git::git+https://github.com/hluk/CopyQ.git
diff --git a/PKGBUILD b/PKGBUILD
index 3d762ebadae8..291bf5bb046b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,36 @@
-# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
-
+# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+# Maintainer: aksr <aksr at t-com dot me>
pkgname=copyq-plugin-itemweb-git
-pkgver=20151130
+pkgver=r4773.2217511c
pkgrel=1
+epoch=1
pkgdesc="Clipboard manager with searchable and editable history. Itemweb plugin."
url="https://github.com/hluk/CopyQ"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('qt5-webkit' 'copyq-git')
-makedepends=('cmake' 'git' 'qt5-tools' 'qt5-svg')
-provides=('copyq-plugin-itemweb')
-conflicts=('copyq-plugin-itemweb')
-source=("${pkgname}::git+https://github.com/hluk/CopyQ.git")
+depends=('copyq-git' 'qt5-webkit' 'qt5-svg')
+makedepends=('git' 'cmake' 'qt5-tools')
+provides=(${pkgname%-*})
+conflicts=(${pkgname%-*})
+source=("$pkgname::git+https://github.com/hluk/CopyQ.git")
md5sums=('SKIP')
pkgver() {
- cd ${srcdir}/${pkgname}
- git log -1 --format="%cd" --date=short | tr -d '-'
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- mkdir -p ${srcdir}/${pkgname}/build
- cd ${srcdir}/${pkgname}/build
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DWITH_QT5=TRUE \
- ${srcdir}/${pkgname}
- make itemweb
+ cd "$srcdir/$pkgname"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QT5=TRUE $srcdir/$pkgname
+ make itemweb
}
package() {
- cd ${srcdir}/${pkgname}/build
- install -Dm755 plugins/libitemweb.so $pkgdir/usr/lib/copyq/plugins/libitemweb.so
- rm -rf ${srdir}/${pkgname}/build
+ cd "$srcdir/$pkgname/build"
+ install -D -m755 plugins/libitemweb.so $pkgdir/usr/lib/copyq/plugins/libitemweb.so
}
-# vim:set ts=4 sw=4 et: