summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48929c44f877
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = coreboot-utils
+ pkgdesc = Tools and utilities to work with coreboot firmware
+ pkgver = 4.12
+ pkgrel = 1
+ url = https://www.coreboot.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = pciutils
+ optdepends = python: me_cleaner support
+ provides = ectool
+ conflicts = coreboot-utils-git
+ source = coreboot.4.12.tar.gz::https://coreboot.org/releases/coreboot-4.12.tar.xz
+ sha256sums = edcad000ee9b73183c396ea76155629b3d27c693e0f1ae83e3424c4d936e2be2
+
+pkgname = coreboot-utils
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d778e6b9e155
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9931cded2e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=coreboot-utils
+pkgver=4.12
+pkgrel=1
+pkgdesc='Tools and utilities to work with coreboot firmware'
+url='https://www.coreboot.org/'
+license=(GPL)
+arch=(i686 x86_64)
+depends=(pciutils)
+optdepends=("python: me_cleaner support")
+provides=(ectool)
+conflicts=("coreboot-utils-git")
+makedepends=()
+source=("coreboot.${pkgver}.tar.gz::https://coreboot.org/releases/coreboot-${pkgver}.tar.xz")
+sha256sums=('edcad000ee9b73183c396ea76155629b3d27c693e0f1ae83e3424c4d936e2be2')
+
+build() {
+ cd coreboot-${pkgver}/util
+
+ make -C cbfstool
+ make -C ifdtool
+ make -C nvramtool
+ make -C inteltool
+ make -C intelmetool
+ make -C superiotool
+ make -C cbmem
+ make -C ectool
+ make -C intelvbttool
+ if [ "$BUILD_AUTOPORT" == y ]; then
+ cd autoport
+ go build
+ fi
+}
+
+package() {
+ cd coreboot-${pkgver}/util
+ install -m755 -d "$pkgdir/usr/bin" "$pkgdir/usr/share/man/man8"
+ install -m755 -t "$pkgdir/usr/bin" cbfstool/{cbfstool,rmodtool} ifdtool/ifdtool nvramtool/nvramtool inteltool/inteltool superiotool/superiotool cbmem/cbmem ectool/ectool intelmetool/intelmetool intelvbttool/intelvbttool
+ install -m755 "me_cleaner/me_cleaner.py" "$pkgdir/usr/bin/me_cleaner"
+ if [ "$BUILD_AUTOPORT" == y ]; then
+ install -m755 -t "$pkgdir/usr/bin" autoport/autoport
+ fi
+ install -m644 -t "$pkgdir"/usr/share/man/man8 inteltool/inteltool.8
+
+ install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}