summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..372a0cc6717d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = corevantage-t430
+ pkgdesc = Graphical user interface to configure coreboot settings for: ThinkPad T430
+ pkgver = 1.5
+ pkgrel = 1
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-quickcontrols
+ makedepends = cmake
+ depends = nvramtool-corevantage-git
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ provides = corevantage
+ conflicts = corevantage
+ source = https://github.com/JaGoLi/corevantage/archive/1.5.tar.gz
+ sha256sums = 42c448d1732981818142b87f248f2410c60320804f3c9591cc43effa5ab92f9c
+
+pkgname = corevantage-t430
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35bff89a824b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jason Goulet-Lipman <jason.gouletlipman@gmail.com>
+pkgname=corevantage-t430
+_pkgname=corevantage
+pkgver=1.5
+pkgrel=1
+arch=('x86_64')
+license=('GPL3')
+pkgdesc="Graphical user interface to configure coreboot settings for: ThinkPad T430"
+source=("https://github.com/JaGoLi/$_pkgname/archive/$pkgver.tar.gz")
+sha256sums=('42c448d1732981818142b87f248f2410c60320804f3c9591cc43effa5ab92f9c')
+provides=("corevantage")
+conflicts=("corevantage")
+makedepends=("qt5-quickcontrols"
+ "cmake")
+depends=("nvramtool-corevantage-git"
+ "qt5-base"
+ "hicolor-icon-theme")
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ cmake -B build
+ make -C build t430
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make -C build DESTDIR="$pkgdir/" install
+}