summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
-rw-r--r--cargo.lock.patch36
4 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2699de84ffdb..07bb3f7c74e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cosmic-notifications-git
pkgdesc = Layer Shell notifications daemon which integrates with COSMIC.
- pkgver = r63.4ea0564
+ pkgver = r68.f72b316
pkgrel = 1
url = https://github.com/pop-os/cosmic-notifications
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..55aa12c745ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!cargo.lock.patch
diff --git a/PKGBUILD b/PKGBUILD
index a16bbf015a7d..81f35201cb69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: soloturn <soloturn@gmail.com>
pkgname=cosmic-notifications-git
-pkgver=r63.4ea0564
+pkgver=r68.f72b316
pkgrel=1
pkgdesc="Layer Shell notifications daemon which integrates with COSMIC."
arch=('x86_64' 'aarch64')
@@ -38,7 +38,8 @@ prepare() {
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
- nice just vendor
+# nice just vendor
+ cargo fetch --target "$CARCH-unknown-linux-gnu"
}
build() {
@@ -47,7 +48,8 @@ build() {
export RUSTUP_TOOLCHAIN=stable
# use nice to build with lower priority
- nice just build-vendored
+# nice just build-vendored
+ nice just build-release
}
package() {
diff --git a/cargo.lock.patch b/cargo.lock.patch
new file mode 100644
index 000000000000..05e9e593446b
--- /dev/null
+++ b/cargo.lock.patch
@@ -0,0 +1,36 @@
+--- Cargo.lock-a 2024-05-13 11:31:36.918208879 -0600
++++ Cargo.lock-b 2024-05-13 11:33:35.493642510 -0600
+@@ -4447,33 +4447,6 @@
+ ]
+
+ [[package]]
+-name = "smithay-client-toolkit"
+-version = "0.18.0"
+-source = "git+https://github.com/smithay/client-toolkit#18070ad8e0675bdf555e6099bf90e3a92adc01b0"
+-dependencies = [
+- "bitflags 2.5.0",
+- "bytemuck",
+- "calloop",
+- "calloop-wayland-source",
+- "cursor-icon",
+- "libc",
+- "log",
+- "memmap2 0.9.4",
+- "pkg-config",
+- "rustix 0.38.34",
+- "thiserror",
+- "wayland-backend",
+- "wayland-client",
+- "wayland-csd-frame",
+- "wayland-cursor",
+- "wayland-protocols",
+- "wayland-protocols-wlr",
+- "wayland-scanner",
+- "xkbcommon",
+- "xkeysym",
+-]
+-
+-[[package]]
+ name = "smithay-clipboard"
+ version = "0.8.0"
+ source = "git+https://github.com/pop-os/smithay-clipboard?tag=pop-dnd-4#ab422ddcc95a9a1717df094f9c8fe69e2fdb2a27"