summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ee504b1ba26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = cosmographia-bin
+ pkgdesc = Cosmographia is a visualization program rendering the solar system and its bodies in 3D to create a freely navigable map of the solar system
+ pkgver = 4.2
+ pkgrel = 1
+ url = https://naif.jpl.nasa.gov/naif/cosmographia.html
+ arch = x86_64
+ license = unknow
+ provides = cosmographia
+ source = https://naif.jpl.nasa.gov/pub/naif/cosmographia/packages/cosmo-installer-4.2-linux
+ sha256sums = 8025d5f14cfd70c94caf8b573eed19c6c5c1862b73a1220eee9e1fbcf224dd75
+
+pkgname = cosmographia-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..114648a9284d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=cosmographia-bin
+pkgver=4.2
+pkgrel=1
+pkgdesc="Cosmographia is a visualization program rendering the solar system and its bodies in 3D to create a freely navigable map of the solar system"
+arch=('x86_64')
+url="https://naif.jpl.nasa.gov/naif/cosmographia.html"
+license=('unknow')
+provides=('cosmographia')
+source=("https://naif.jpl.nasa.gov/pub/naif/cosmographia/packages/cosmo-installer-${pkgver}-linux")
+sha256sums=('8025d5f14cfd70c94caf8b573eed19c6c5c1862b73a1220eee9e1fbcf224dd75')
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ chmod u+x cosmo-installer-${pkgver}-linux
+ ./cosmo-installer-${pkgver}-linux install -t "$pkgdir/opt/cosmographia"
+ ln -s "/opt/cosmographia/Cosmographia.sh" "${pkgdir}/usr/bin/cosmographia"
+}